Naim app MIA after ISP upgrade

Naim app (Android) won’t recognise my N272 since I had a new fibre internet connection installed a few days ago. I’ve tried all the usual cache clearing, app reinstall, device switching on / off, etc.

Router settings indicate firewalls and various filters are all switched off and the network is working perfectly well otherwise. I’m still able to access my radio presets via the Naim remote and also Tidal via Audirvana on my Mac. In other words, I can manage fine without the Naim app, but still…

Any thoughts? TIA

Yes almost certainly it’s an interoperability issue with your new Wi-fi access point on your isp router with your Android device for those protocols and network methods that Naim need to use for its software.
Unfortunately the most most likely solution is to replace kit like Wi-fi solution, or move to iOS which seems better behaved on the whole, or even try a different Android device… all require some trial and error.
All in all I do recommend a wifi solution that is quite seperate and not dependent on your ISP access router, for precisely these reasons.

Thanks Simon. The new router is a GPON model with a direct fibre connection so not a simple task to swap out. Seems it can be configured to work in bridge mode, but that also looks a bit fiddly, especially given my location (Thailand) – the relevant YouTube how-to video is in Thai… !

Can you disable its Wi-fi?
If so you can plug a seperate wifi solution into its switchport(s)… such as a Ubiquiti solution or equivalent.

Further you should be able to get a GPON (FTTP) NTE in your region which is a fibre equivalent of a modem, and plug into a seperate router using its WAN PPPoA or PPPoE interface… but as you say a little involved… easier to disable the wifi.

Yes, I can turn off the router’s wi-fi. I’ll experiment over the weekend - and report back here once I’ve bricked the router and have no internet or music.

Re your avatar: I was also traumatised in the early 70s by The Hood and his auto-illuminating eyes (not to mention his outsize eyebrows). TBH I found the recent discussion on another thread somewhat triggering.

But given your de facto role here as a sort of networking International Rescue, maybe another avatar would be more appropriate?


Given the way some of the streaming threads and challenges go, this would be equally appropriate(?)


Or perhaps

As someone who spent the first third of his career as design and tech support for the early UK data networks PSS and Framestream, this xkcd cartoon resonated, and reminded me of a lot of threads here.

Other than these days, everybody seems to blame IT problems on the ‘network’ and invariably it’s anything but… if only computers and many software applications were as reliable as data networks…


‘‘Twas ever thus. Back in the ‘80s we offered 3270 and SNA transport over the X.25 network, and the computer vendor who wrote those protocols (he says not naming names) had hosting sites in the U.K. with lots of customers connected to our PSS network. The standard response to pretty much any fault on a networked application seems to be ‘It’s the network”. I spent a lot of my time proving the issue back to the computer side, and was usually vindicated. I seem to remember in one case Armonk even rewrote an SNA handler to fix the bug I demonstrated, after 3 weeks of stress with the end customer.

To be fair the pre Internet PSS networks were nor always as robust as they should have been :grinning:

I wrote my first commercial software decoding to help debugging X.25 traffic for the then EEC CTS-WAN programme… it was written in awk of all things for computer portability… it worked rather well though I say it myself :wink:

1 Like

See, the bl**dy coders always blamed the network. :grinning::grinning:

1 Like

Nicked from a Facebook post from a friend, Due to COVID-19, all TCP applications are being converted to UDP to avoid handshakes.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.