Naim app not working with Muso QB mki

Good day,

I have a qb and Muso2, linked to a new Core.

If I go into the Muso2 via the app, access the Core, album etc, everything works fine.

With the QB (mki) I can access ripped albums through the same route. I select the album, and see the track list. I press play from the middle bar in the app. The music starts. But if I then press the banner at the bottom (UPnP) all I see is the icon and volume. There is no track identification at all. But also no ability to switch tracks or end. The only way to end playback is to exit the app completely.

I can track change using the remote.

Tidal through the qb works fine.

A workaround for the Core is to use the Muso2, and multiroom, but is a pain. I have the most up-to-date firmware on all, and have tried de-powered reboots.

All Naim firmware/software is up-to-date.

Android. Different Samung devices provide the same outcome.

As the Core is new, I cannot entirely remember whether it worked before the recent software upgrade but I would be surprised if it did not (as surely that would have been a major Core-qb fail.

Any suggestions?


How have you got the three units connected? For example are you using WiFi or Ethernet cables and when you play from the Core, in both cases you are doing it using upnp or servers, rather than as a digital input? So the music is controlled via the Muso 2 page in the app and the Qb page in the app and not via the Core page in the app?

Thank you for your reply.

Ethernet into the Core (of course). Wifi to both Muso2 and Qb. Music accessed via the streamer, then choosing the Core option. As you allude to, in the Muso2 it is ‘servers’, in Qb = UPnP. Presumably that is just nomenclature though.

I actually have tested 2 different Qb (in addition to Muso2). Same issue on both Qbs so it is not related to a specific unit.

The WiFi on the Mk 1 Qb is rubbish, so the first thing I suggest is using an Ethernet cable for that unit. They don’t cost much and you can lay it across the room or whatever to test whether it fixes your problem. If it does then you know what you are dealing with. If necessary you can move it close to the router to try with a short cable.

If it is simple as (it probably isn’t…) plugging in a ethernet cable into the Qb, then that made no difference. I tried the UPnP ‘input settings’ too. That made no difference either.

Should wifi selectively affect Core/servers vs Tidal or multiroom?


It is as simple as plugging in the Ethernet cable to the Qb and router although you might have to do a restart of the Qb to force it into the Ethernet (but left to itself it should get there on its own in a few minutes).

The ongoing handshakes between different music sources and the player aren’t necessarily going to be the same in each case. So a marginal WiFi link could mean you get all sorts of difficult to explain issues.

Having said that, I have just used my iPhone to tell our bedroom Qb series 1 to play a CD rip from my Core, and even though the Qb is WiFi connected, it all works fine.

Thank you for testing that.

Perhaps it is then an android/istuff issue…

I can’t test Android here and anyway it may depend on the smartphones you have tried. There isn’t a known issue such as you describe, or you would read about it here quite quickly. So it’s likely either an issue with your Qb talking to your router or a rarely seen android app bug.

I suggest that unless anyone else here has ideas of things to try, you contact Naim technical support again next week when they are back from the holidays.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.