Naim App on M1 iMac - UPNP problem

Hi folks, I know a few people on here are using the naim app on a mac using Big Sur, and I have the app loaded can stream radio, Tidal and change volume and inputs on my 272 and NDX.

But…it will not connect to a synology NAS. I just get the scrolling wheel.

I have deleted and reinstalled the app, no change.

NAS is still on DSM6.2.4, does it need to be updated for this to work?

Any ideas welcomed.


Is the NAS on the same local network as the iMac?
Can you install the Naim app on a mobile device and try if it works from there?

What UPnP media server is installed & running on the Synology, that is what the Naim app is searching for, not the Synology as such.

1 Like

I use the app successfully on an M1 MacBook with Synology NAS. It’s running Monterey rather than Big Sur, but I don’t think this should make a difference. I’m also on DSM 7, but again I doubt if that’s the issue, but could be wrong. I have MinimServer and Asset and the app finds both.

Do you have or could you download the VLC app on a tablet or your Mac and see if it can find the server on your NAS? That might help to pin down the problem.


Go to your Synology control panel.
Under the file services tab check if SMB is enabled.IIRC afp connection does not work anymore in Mac OS Big Sur or Monterey.

1 Like

I know very little about Mac products (I’m Windows) but I normally have my Synology SMB disabled. The iPad & Android phone with the Naim apps will still open Asset UPnP & browse & play the NAS music share.
The reason why I have SMB disabled is to reduce the unwanted hibernation wake ups, I just enable SMB (tick the SMB box) when I need to write (upload or edit) to the music share.

Its nothing to do with SMB.

Try installing NetAnalyzer on the iMac and see if you see the NAS in the UPNP section.

Also check DNLA/UPNP is enabled on the NAS firewall.

Just so. Streaming from my NAS works fine whether I have SMB enabled or not.


Hi Suedkiez, yes I should have been clearer. All wired system, NAS on same LAN.

Hi Mike-B, Asset is loaded and works a treat on iPhone and iPad.

Try going into Settings, Security and Privacy. Then Privacy tab. Select Location Services, and check Naim app on right is Checked

Thanks GadgetMan, already tried that, naim is ticked. Also tried adding to firewall permissions and no joy.

I have this on my iPhone, and it shows the synology NAS with the name I have given it (Music Collection), and in any case both iPhone and iPad access and work NAS from the naim app.

Thanks for your input.

Another piece of the jigsaw, is that I can select something to play from the NAS using iPhone or iPad, and it appears on the naim app on the Mac on the bottom info/volume bar, but the spinning wheel will continue and it will still not find the NAS!

Try it on the iMac, I’m not sure what the Mac does with iPhone / iPad apps, it may block traffic, just a thought.

I’ve got a trash can mac pro so can’t run iPhone / iPad app.

Also try switching off the firewall in Security & Privacy.

OK, that indicates the problem is in the iMac to Synology interface, maybe a permissions block.
That’s me out, non compredi Mac stuff

Thanks anyway Mike for having a go!

Thanks, already tried that on the Mac and it didn’t work.

As the NAS can be seen by the streamer (and using remote select any album/track using the screen and buttons or remote) I’m assuming the NAS firewall setting DNLA/UPNP are set correctly.

All very odd.

I assume you have tried a reboot - sorry if a dumb question

Can you also describe your network setup - e.g. routers/switches/Powerlines/wifi extenders etc?