Naim app (V6.5) missing from App Store on Silicon Mac

I see Naim have just released Version 6.5.0 of the App on my iPhone. I went to update the Mac Silicon version, but has disappeared from the App Store (yes, I did check iPhone &iPad apps tab).

Not sure of this is temporary, but has anyone else seen this issue?

The plot thickens. If I click on my account on bottom left hand corner to see my purchased apps, it is there, but when I click on it I get:

then lower down I get
Screenshot 2023-10-30 at 16.25.33

However on a working app, I get this

So looks like Naim have removed the compatibility option for running off a Mac. I really hope this is an oversight, as it’s something I use nearly all the time, and I know others do to

Just updated my iPhone and iPad app to 6.5 - all OK, but as you say Naim app is missing from Apple Silicon App Store.

@Stevesky can you possibly confirm if this was intentional?

Same here. Hope this is temporary.


Removing it from App Store would be an awful decision.

Here here. Thankfully the V6.4.x version still works

Is there a Mac app now? I must have missed that.

It’s the iPhone/ipad app. Those apps can be used on MacBook with M1 chip and later.

1 Like

Do please make this available again for Apple Silicon Macs: it’s really useful to be able to run it from a Mac.


1 Like

I have reported this in the beta group, so I expect Naim will see it in the morning.

Thank You!

Strictly, it (and many other apps) aren’t specifically designed (guaranteed at least) to run on an Apple Silicon Mac but prior versions have worked. I don’t know if there’s something during compilation of the app which flags ‘might work’/‘will work’/‘won’t work’ and adds it/removes it from the store for donwload/update or if it’s somthing the developer specifies.

It would be interesting to know - can you clarify @Stevesky ?

To be honest if I get something working from iOS/iPad OS land on the M1 Mini I make a backup of the app in case an update breaks existing functionality or stops it working - generally backed up to an external drive +/- right click on the working version and archiving it - possible to have several different versions active sometimes if not careful.

Not sure if it’s normal but ‘Updates’ only seems to show me macOS apps currently and with poor icon resolution.

In the purchased section of the user account it still shows the app as recently updated but no update to download, top of page suggests it’s no longer compatible:

Version history currently saying updated 10 hours ago:

May or may not be relevant but there’s an Apple ‘Event’ at 5 pm Pacific Time, potential new hardware etc. Suspect there may be a lot of back end tinkering on many Apple sites pending announcements.


Well that works:

If you notice on your first graphic, the Open is greyed out

Good idea about app backups - Time Machine should take care of this

1 Like

I don’t trust Time Machine alone for some reason, but most Apple strategies work pretty well.

Hadn’t noticed tbh but I have the old Naim app on this Mini:


Possibly still works:

Seems to anyway:

Hi All,
It should be on the Mac App Store by now, please let me know if it’s still not showing for you.



n-Serve only at the moment.

Will check later.

Well it didn’t come up in the search for “Naim” apps, but going via the account (bottom left hand corner of the App Store) when looking at existing apps, it allowed me to update the app, and it runs successfully on 6.5.0 - many thanks Paul.

I’ll keep an eye on seeing it at the search level, perhaps they need to sync their servers …

1 Like

Yes, my search was from search level not via account level. Do not have it installed on my Mac so it didn’t come up. Hopefully they sync at some point otherwise I will not be able to try it out on my Mac. Probably not the end of the world if not as I tend to use iPad or iPhone for Naim control.