Naim App won’t play 1st track on album

All of a sudden I am really struggling with the Naim App. When I try to play an album from my Qnap through my NDS it always misses the 1st track and just starts from track 2.
Any help would be appreciated.Mark

I confirm it is the same for me.

Several questions, if I may, which may aid with a discovery of what is causing this behaviour:

  1. What UPnP server is being used?

  2. Is it one track in one album, or does this happen to all albums?

  3. What file format (for the album tracks) are being used?


Hello Adam
I am using Minimserver for the last 5 years. This problem has only just started on Every album

Its not a problem with the app, its just a dumb reader, it shows what the server sends it.
I had the same with Asset, it was something I did with the browsing tree.
OK OK its not a solution, but I would look into Minimserver, maybe a good idea to ask the question on their forum.

Hmmm… odd…

Just one more question, before we start trouble-shooting:

Has anything changed recenty? Software update on the MinimServe / NAS or any other network component?

Same here using Minimserver on QNAP. A work round is to click on “tag view” on Naim app. If you then play the album it should start from the first track.

Hello Adam

  1. Minimserver na QNAP
  2. The first song is always dropped on every selected album
  3. FLAC


Thanks John

Only think that has changed for me is the Naim app.

Jacow never lost the 1st track in the last 5 years. Only just started happening.

Suggestion for MinimServer users on this thread

I suspect there is something off with the MinimServe.

Could you please run the following experiment and report back your findings?

Please play back some albums using different views:

  • Tag
  • Album
  • Artist and Album
  • Folder view

I suspect one of these is ‘broken’ somehow in the coding.

As @Mike-B wrote earlier - the Naim App is a remote control and only shows what the UPnP server does.


As I said in the earlier post, I had it before with Asset, I fixed it by doing something with the browsing tree @ the attached +root level. I suspect its the same/similar with Minimserver. Sorry but I can’t remember the detail & I’m away from home at the moment & can’t go looking in Asset for clues.

@Freightliner, @Jacqw: could you try to reproduce the issue by replaying on your mobile device using somehting like VLC, BubbleUPnP or AirPlayer?

If this works fine then you at least know for sure that the culprit cannot be your UPnP server.

The recently updated naim app is the problem. Before this it worked fine.

I understand but still it is better to run a definite test than to rely on a conjecture that is perhaps very plausible but not certain.

It’s not conjecture. I’ve tested the other possibilities and it comes down to the recently updated Naim app as the changed variable.
This with QNAP and Minimserver.

Thank you John - its a real pain. (Why did i ever get rid of my CD player!!!)

Hello John

I doubt it is a fault of the app.

Both @Mike-B and I are Naim Beta-testers.

We’ve seen really odd things during Beta testing, but not 1st track skipping.
Given a decent number of Beta-testers, one of us would have spotted such an undesirable behaviour. We typically run a Beta-version of an app for weeks, before it is released by Naim.
Naim developers are directly involved with us and every odd bit is immediately passed on to them and eliminated in the production version of the app.

That is why I’ve asked for a series of tests to be run, testing the UPnP server.

Best regards,

Seems odd then that three people using Minimserver have experienced the same problem since the app update.
Before discounting the app, did any of the beta testers test using Minimserver on a QNAP NAS?

As posted, I can get it to start from the first track by resetting the album to tag view on the app.