Naim MuSo keeps appearing and disappearing from the app

tonight my Naim MuSo was nit reachable anymore from the app.
I tried to turn it off, turn it on, reset via the pin hole. nothing changes. I even restarted my iPad.
In the app my Muso appears for some seconds (but I can’t select it) and then it disappears again.
It is connected via Ethernet.
What else can I try?
Tonight I will leave it disconnected from the power line.



Try turning off the muso and your router. Wait a few minutes then turn the router on. Let it boot up, and when it’s ready turn on your muso. See if that works.

1 Like

Yes, I would try power cycling your router and any switch you may have. Also power cycle the Mu-So with a full power down (plug out - wait 5 minutes - then plug back in).

1 Like

Hi, and thanks for the answers.
At the end it was a power line adapter that was somehow stuck. It was losing and delaying packets.
After having pulled it off and put it back in everything worked as expected.

Thanks again,


They’re horrible things those Ethernet over mains devices. Best replaced in my view.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.