Naim ND555 Struggling to Find Melco Server

I have just purchased a ND555 and using a Melco server N1. I am using the Naim App on my Android 9 device and it struggles to find the Melco server. The only way to get it to display the Melco server is to swap inputs or close/open the app a few times.

I didn’t have any problems when using my NDS and Melco on the same network , nothing has changed apart from swapping out the NDS for ND555.
Everything is hard wired and hence not using the WiFi network

Has anyone come across this problem and have a potential fix?

I have tried Bubble upnp and that works no problem it see’s the Melco server without any issues .

I am getting quite frustrated with this issue :disappointed: and raised a ticket with Naim support.

Have you tried turning off router, any switches etc and then powering back up, starting with router first, then switch etc…leave each on for a good few minutes between powering the next one. See if that helps?

I have not , but will give this a go . Thanks

It’s always worth a try🤞🏽

Just tried it , it listed the Melco , whilst listening go back server its disappeared , only item i see is the local music and maybe after 30 - 60s it reappears.

I have exactly the same issue on my ND555 - the Asset UPnP instance is never present when first selecting NAS as a source but will eventually pop up, and worse [or as bad] is that if I fancy adding to the current play queue and navigate back to find another album that album will show as having no content, so then a further Back > Back > Back to the server shows - yep - Asset has gone missing again, but will appear after a delay. Once it’s reappeared I can select more music, but it’s hardly seamless and smooth.

Never happened on the 272, drives me nuts on the 555. I have raised it with Support and need to follow up tbh but for various reasons it doesn’t get much use anyway these days so it’s not the most pressing issue. Per suggestions above, yes the full end to end reboot of all network components didn’t solve it.

I’m glad someone else is seeing this too - maybe it’s a bigger issue than just one set of permutations causing it to happen locally.

@HouseholdNaim , I am seeing the same issues as you , where the album art is missing or duplicated on other albums.
The annoying server not present every time I launch the app or when the app is idle

I did try a full power off my network , starting with router , switch , Melco , ND 555. Powering them on in that order and still no joy .

I have also raised a ticket with Naim would you mind if I could quote you having the same problems?


How did you try Bubble upnp into Melco server?..i know there is only two options…Twonky or Minim

I am just using the standard bubble upnp/dnla supported by bubble/android

If so i think you don’t use Melco benefit which was your first reason to purchase

@ Meni , I am not sure what you mean?

Never mind I’m either

Hi @Confirm74 - no probs. Tbh seeing this thread earlier on today nudged me into picking up the email chain to Support again, so I’ve referenced this thread. The very helpful Duncan is on my ticket, if yours has a different name on it it’s probably worth you cross referencing your ticket to mine via this thread.

Fingers crossed eh?

Yes - happens occasionally here! :confused:

My only solution is to go to front of Melco - navigate to the ‘Twonky Service’ (if that is what you use on Melco like me) - stop it - wait until it stops - then start it again.

Then within a minute or so the Naim App shows it as an available item and you are back running with it for a few months again - until it happens again = repeat above.

Hope that helps - post here it it works, as it is at least easy to try.


1 Like

The problem there DB is that [from my pov] Asset will reappear within a minute anyway, and restarting it causes it to do a full scan which takes upwards of 20 minutes so that’s not a worthwhile fix.

The bigger question is why did previous streamers not show this issue? Mr Confirm’s NDS was fine; my 272 never lost sight of Asset or any servers that I tried - Minimserver amongst them. The ND555 might be fabulous when it’s working, but having to wait every time while it has to recognise the server before letting me add another track, is a bit poor.

It seems that it is by design too - that’s 3 reports of the same issue.

I’m not claiming it was a cure or even a great solution - but it is the only one I found that worked.
I personally don’t like that I occasionally have to do this, but when you want to play your music and there is not a solution forthcoming from Naim then I do what I have to do - so it was just for information if OP was desperate for a work-around until, hopefully, Naim fix it - if they admit it is their end the issue.

As always it can be that the guilt for the problem is said to ‘not be at our end’ - both ‘ends’ say this and the user is stuffed - I’d used a stronger term but forum etiquette forbids. :slightly_smiling_face:

I’d like a nice solution along with a few other niggling operational things that irritate me with ND555 - but its saving grace is that it sounds sublime …but it would be nice for it all to work seamlessly as you would expect I very strongly agree!


If anyone is also encountering this, mine is resolved. How?

I installed a mesh network late last year to improve home wifi, and switched off the existing wifi as recommended. For various reasons this 555 issue didn’t tie in with the time of that change, and over time as listening via the NAS became more of a chore the less the NAS presented itself as a source of choice. There’s a lot of high quality internet radio out there, and Tidal.

Following a suggestion in the latest support email I’ve switched the original wifi back on and connected the iPad to that, with an instant fix - Asset now appears in the server list, and doesn’t disappear when backtracking to select more local music.

I expect someone can offer an explanation as to why accessing Asset on the Pi via a mesh is no good but is fine through the original wifi, but for now I’ll take it as a result.

1 Like

Thanks for the update.
Did you try the app on an Android device ?

I just have (Android phone) and it’s good on there too.

1 Like

I am still awaiting Naim support to contact me ref my support ticket.

My whole system is wired so the only wireless element is the app on the phone . Both the ND555 and Melco are wired on the same switch .
Really baffled what is going on?