Naim Nova and Chromecast (not working)

About a year ago I started a thread about Chromecast not working on the Nova. A lot of people kindly commented and I tried a few things. But I never got it to work. Now, after several firmware updates, I figured I would try again. Here goes…

  1. On the Naim app I can see in the settings (sources tab) that Chromecast has an IP address. So I guess it is at least a bit alive.

  2. When I try to select Chromecast from the front display of the Nova there is no Chromecast option.

  3. Inside the Naim app on Android phone Chromecast is available, but when I select it, it automatically reverts back to the previous source. BTW: I have tried several Android devices including tablets and new phones.

  4. In Google Home app the Nova does not appear as an optional device to stream to. Likewise in Spotify app. Even when I search for ‘new devices’ it does not appear.

  5. All devices are on the same WiFi network.

We want to play some podcasts etc. But have to use our TV and Amazon Fire as this works. Seems nuts to have to leave the TV on to listen to podcasts when the Nova is supposed to be Chromecast compatible. If the Amazon Fire works… why not the Nova?

Many thanks

I had issues with ChromeCast when I first got the Atom. When you set it up for the first time you have to authorise it with the Naim app and this registers it with Google. With my Atom this stage cocked up some how and it would never authorise it. Naim support had to contact Google to reset it so it would re-register and then it worked fine since then. Maybe this is your issue to.

Do you have other Chromecast devices? Do they work on your network as it may also be a router issue blocking discovery.

Thank you CrystalGipsy. That would be a good explanation as I have run out of things to try. I’ll send them an email and hopefully it can be resolved.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.