Naim QB, Muso and Atom multi-room issue

Can anyone offer any thoughts on multi-room with Naim units I have. Could not find anything in the existing listings

I have the following Naim units:
QB 1, QB2, Muso 1, Atom, Uniti Core

Core, Atom, Muso and QB2 are hardwired (power line), Muso 1 is wireless. I can see all of the devices in the Naim app on iOS and iPad.

Whenever playing via streaming radio local device or music file from the Core, I am experiencing issues with multi-room as below:

  • QB1: Multi-room play to Atom, Muso, cannot see QB2
  • QB2: Multi-room play to QB1, Atom, cannot see Muso
  • Muso: Multi-room play to Atom, QB1, cannot see QB2
  • Atom: Multi-room play to QB2, QB1, Muso all correct

I have only recently tried this so I cannot know if this is a new issue or long standing. All firmware is updated. I am now at a loss as to what the issue is.
Puzzled!!

You should, in theory, be able to put any combination of Naim streamers into a multiroom group.
(An exception is that the 1st gen. streamers can’t multiroom HiRes files, but iRadio and 16/44.1 files should play.)
I’m always suspicious of powerline adapters for networking. While they are easy to set up, and can work well, they are notorious for causing issues, and do not conform to the Ethernet standard. It might be worth testing some of the pairings that don’t work over WiFi to see if the problem persists.
Ideally you would just use Ethernet cables. It’s generally the cheapest and most reliable way to run a network. Also consider a Mesh wireless network, which can also work very reliably if set up properly.

My guess is you app can see all because it is wireless and sees them via the router. Maybe the individual boxes can’t find the others because of the way your house is wired. Maybe try them all wireless? Or try running them all in one room with hard ethernet wires then consider an ethernet system or yes a good mesh system may solve the issue - Orbi or similar.

Many thanks to both for the feedback. I took some time out today to do some troubleshooting based on your feedback. All devices were setup wirelessly and the multi-room worked perfectly. I then systematically connected them back wired and the issue returned.
I have been able to put the cause down to the power line adaptors which will not share data between the separate ring mains of the house. Where it does work I presume this is down to the wireless setting. Is it known if multi-room uses wireless or wired by default.
Thanks

I think you need one more Naim unit :sweat_smile:

1 Like

Multiroom will use whatever the streamer is using for regular use, whether that’s wired or WiFi. If you use WiFi you may find that multiroom struggles more, especially with the 1st gen. streamers which have very dated WiFi modules.
Still, you seem to have identified the culprit. For a long term solution, if you can run proper Ethernet cables to your streamers that’s likely to be the best solution and probably the cheapest, although it can be disruptive running cables everywhere.
Alternatively consider a decent Mesh WiFi setup. Some of these also have Ethernet ports which you might use to connect some of your streamers.

Thanks all for the feedback. I’ll soldier on with PL for now while I look into wired/wireless mesh network options :+1:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.