Naim streaming and qnap nas

I have had to replace my qnap NAS after a disc failure (it was running 24 /7 for 12 years). After successfully transfering music to my new qnap NAS, I am now attempting to connnect to my Nd5 xs2 through the Naim app but unable to locate the NAS in rooms. The systems are all on the same network, i can play from the NAS to the Nd5 using qnap music station so the connection is there. It’s a wired system

I don’t own a pc and everything was set up using Chrome browser on my tablet, so a solution using a pc is not possible. I have tried all the solutions suggested on this forum, powering off and restarting, router, Nd5, NAS, network switch after every attempted fix but to no avail.

My Asus Router can see the ND5 and Nas. Unfortunately my old NAS is being reformatted with new discs so i can’t just plug that back into my network to replicate the previous working system.

If any good has came out if this it’s the fact i have now finally signed up to this forum after being a long term lurker. Any suggestion would be appreciated.

You can’t connect to a NAS on the Rooms screen. The Rooms screen lists the Naim streamers in the network, so the ND5XS2 would be there to choose. You must enable the UPnP server on the NAS, or install one, and then you can find the NAS in the Server input in the Naim app after choosing a Room such as the ND5XS2


Hi @Dave101 and welcome to the forum. I assume you were using a UPnP server on your previous QNAP. If so, the new NAS should work in the same way, though you may have to go into the configuration page for the NAS to start the server going. (I can’t remember if it’s on by default.)

Incidentally, if you don’t have a computer, you might want to download an app called Qfile which allows you to manage your NAS from any fairly recent iPad. If you have a different make of tablet, I guess there will be a similar app available.


Ok, i could have worded it better. I have qnap server running
and Nd5 x2 can’t locate it.

OK :slight_smile: So you have the ND5XS2 open in the Naim app, you tap the Servers input, and the NAS is not there, correct?

I don’t quite understand what “I have qnap server running” means, but I am assuming that a UPnP server is running on the NAS, such as the built-in one (Twonky I think), or you installed Asset, Minimserver, or similar.

I would verify independently that this UPnP server is accessible and works. Can you install a UPnP app on the tablet, such as BubbleUPnP on Android, and can this see the NAS’s UPnP server and play from it?

Thanks Roger and thanks for the welcome. I have all the Apps i need. I can access my router,- Asus app and my Qnap- qnap apps, so no problems that way.

The only thing i can think of is my mimum app on previous system was running 0.8. My new server has version 2.0 that i cant open from Qnap cloud. Previously both the Qnap and minum servers where available when i opened the Naim App so just trying to run on the qnap server at the moment

I will try BubbleUPnP, thanks Suedkiez.

I got Bubble running on the Naim app. i now have some of my own Flac files available, i can only listen too so much low quility Radio. i will look into configuring it into the Qnap NAS, or possibly something like Asset. Thanks for the replies

There is a free music app for Qnap which may be worth trying - works for me. If you can’t access that then Asset Minim probably won’t work either and there is another problem somewhere.

Is the server input enabled on the app?

Can I suggest looking and perhaps posting on the Minimserver Forum. It’s a friendly and helpful place and Simon Nash, who wrote the software often posts. Hope you get it sorted.


Minimserver 2.xx is a totally different app from .8, it’s no longer free. If you want to use Minimserver you have to buy a license.

There is a Starter version, best thing is to check out their web site

The basic MinimServer application on my Qnap works fine for presenting my music files on the Naim application on my Android phone and iPad.

What Version is it?

Just a wee update. I have made a temporary solution till i get to the bottom of this problem. I copied all my music to a hdd box, copied my music over and plugged it into the Nd5x2 usb port. The naim app now picks up my music collection.
I think it’s a problem with the qnap as the bubble app cant pick up my NAS either, the minum appp cant be opened from Qnap cloud, and as i said i have no pc to directly access my NAS. Looks i will need to build a PC next weekend.
I will decide if i want to go down the minimserver route once i get the NAS visible on my network. In the mean time i will scout the internet (qnap forums) for a solution.

Ps pev99 i can play music directly from Qnap music app to my Nd5, but the Nd5 cant locate my NAS.

Thanks for the advice folks

I know it wont be a final cure but may help with diagnostics and apologies if you have tried already…
Set up the streamer via wifi instead of direct cable and see if you can see the NAS then via the app.

I will try this Neilb1906. I have not set up wifi or Bluetooth,in fact i haven’t even connected the aerial’s on the streamer as i thought my wired network, that has served me well over the last 10 years would be a plug and play job.

Time is a problem just now, i may have to wait until the weekend. Thank you Neil.

1 Like

Minimserver 2.xx is …. no longer free.

Actually it does offer a “starter edition” which is free. It’s functionality is somewhat limited compared with the full version, no on-the-fly transcoding for example, but it may well be adequate for the OP’s purposes.


After buying the nd5 x2, minimserver is a small price to pay. I am still trying to get my UPnP sorted on my network. I will post when i get a fix. Thanks Roger

The default MinimServer app from the Qnap store is free and there are no limitations that I have come across. I would recommend installing it and trying it out.