Naim SuperUniti - TIDAL streaming problem


I am struggling with currently with Naim iOS app - Iphone 8 / iOS 13.1.1 (crashing all the time when boot) and unfortunately I can’t use Tidal on my Naim SuperUniti because of that. With Spotify I can easily connect by Spotify connect but with Tidal the only way I know was the Naim app (Tidal native app doesn’t see the device - only Chromecast connections with TV etc.).

Do You know some other ways to use TIDAL other than Naim app - despite it’s not working right now, the app is not very user friendly so I am looking for some alternatives.

Thanks in advance!

1 Like

I haven’t heard of this crash recently. I hope you agreed to let the app send the crash data to Naim? You might want to email Naim technical support to make sure they are aware of the issue. The next release of the IOS app to go with the Qobuz firmware announced a few days ago can’t be far off now. Maybe that will fix the issue.

Which version of firmware have you got on the SuoerUniti? Did you try restarting the SuperUniti?

As to other ways to get Tidal to your SuperUniti, although I haven’t tried it with Tidal, I am a big fan of the Chromecast Audio dongle which you can connect to your SuperUniti digital input with a fibre optic cable. Google stopped making them unfortunately but there are lots still available through eBay etc.



Naim Technical support is already aware - they explained that “The notification that you are receiving is reported from apple not our app, so I can only suggest that the fault is related to your device” but I don’t buy it as I have also checked on other device (iPhone 7 / iOS 13.3) and this issue also occurs.
I have the 4.7.00 version, tried many restarts etc.

That strikes me as an absurd excuse from Naim Support. Your phone saying the app crashed is unlikely to be your phone being wrong!

However I would certainly suggest trying another iPhone/iPad. Perhaps get a mate to come over and put the Naim app on their device.



Naim might just be right, despite the fact that it happens on 2 devices.

One of our iPads recently became very unstable, random application crashes on a number of applications including Safari, Roon and others.

A hard restart (power key and home key) helped a little but in the end I resorted to resetting the device, restoring from the last backup. It’s now fine and far more stable.

Hi. Did you try to update iOS software? I have some issues with my SU and Tidal but never something like this. Powodzenia

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.