Naim unitiserve connection

I cannot get my Unitiserve to connect to my laptop. I have bought this second hand to rip my CD collection. My Naim app for my Muso cannot find it at all, its not listed as an item to add either. I tried to access online and its telling me the site is not supported ? Does anyone know how I can actually access this unit? otherwise its going back.

To access it you need the nServe app, which is different.

Quite honestly you’d be better loading dBPoweramp on the laptop and ripping to flac. The Serve is massively out of date and I’d send it back.

1 Like

You should see the Unitiserve in the normal Naim app, but only when you select upnp (or servers) in the Muso home page.

As HH says, you need the n-serve app (for IOS or Mac) to directly access the Unitiserve. There is also a Windows desktop client. But nothing for Android or Linux. If the Unitiserve is on firmware lower than 1.7c then you will need to upgrade its firmware before you try to use it. You get that 1.7c firmware update by phoning Naimsupport. They haven’t put it on line, although you can get it online from the German Naim importer, Musicline, bizarrely.

Personally I wouldn’t be buying a Unitiserve now. The operating system is windows XP embedded and is out of support from Microsoft. If you get a hard disc failure, which is common, then the only option is a repair at Naim which is several hundred pounds. On the other hand another common failure is the CMOS battery and that is a DIY fix if you are comfortable with going inside a computer.

But if it’s all working properly then it will do your ripping fine. This is a £2500 machine that you probably got for £300 or less. So in that context it’s worth persevering with.

Oh and you need to enable SMB1 in your Windows PC if you are trying to access the Unitiserve over your home network. SMB1 is turned off by default with Windows, but still works with Mac.

1 Like

Hello Ted

If you decide to keep the US, then a couple of suggestions for ripping your CDs. The first is to set the US so that it rips them as FLAC files. The default is WAV, and the way US stores metadata against WAV files is proprietary to Naim, so if you were to try and use those WAV files on another device in the future you would lose much of the metadata. Ripping to FLAC solves this, and if you want to have the files streamed as WAV you can set the US so that it transcodes from FLAC to WAV.

And the other suggestion is to make sure you have a backup. The easy way to do this is to set up a network share on a NAS or similar and use the Backup functionality in US to automatically run backups.

Setting these things up is best done using the Windows desktop client that David H mentioned.

There are lots of valid comments in the thread about US becoming pretty long in the tooth now, but if you got yours at a sensible price then it’s still a decent one box ripping and streaming solution. I gave mine to my brother last year and he’s delighted with it. It took him a while to get it talking to his PC over the home network so he can transfer downloads he had purchased, but he got outstanding support from the Naim support team.


1 Like

There is a reasonable chance being second hand it has an fixed ip that is either out of ranger of your routers or is conflicting.

On a pc you can download the Naim ip tool. Put the serve on the network via Ethernet let it boot up then run the tool which hopefully will find it. Then set it to dhcp.

Hi David
Thank you very much for your information. I have now managed to load Naim desktop client on my laptop, so at least i can now access it. However the client software needs updating, as my unit is running on 1.7b until i can somehow get that upgraded too.
Can i ask, if i set the unit to rip in FLAC, how do i set it to output in WAV? or indeed any other format. I would quite like to sometimes listen through my LG tv which is on the same network. However LG do not support FLAC for some reason. Can i set the playback to any format via the unit?
Kind regards

Hi Ted

In the DTC tool, go to the Tools tab, then click on System Settings, and there is an option in there to set Transcoding to WAV (with some different choices around sample rates, bit depth, etc.). I don’t have access to it anymore so can’t remember exactly what the option is called but hopefully you can figure it out from there.


@ChrisSU is your guy

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.