Naît 5i (italic) volume light not working

Have a problem with with the volume light no longer working. For a while, it went on at 10:00 position, the only at 12:00, now not at all. No longer blinks on mute. Please help this ‘guy from the colonies’ (Canada) find an easy solution. Eg: open casing and spray Deoxit on the volume control?..
Thanks in advance.

Is it switched on altogether? I.e remote in pre mode, press DIsp

Unit is not on and has been functioning flawlessly for many years. I use a Logitech Harmony remote with programming which automatically chooses input for what I want to do : eg. Listen to vinyl, digital steaming, watch movie etc. The Naïm logo is lit, as well as input lights, but no volume setting/mute light.
I just found the Naïm remote, changed the batteries and pressed on ‘prog’ and ‘disp’ at same time. Nothing new or different. Volume is adjusted with remote, but no lighting on the volume knob.
Am I doing somethIng wrong. The remote instructions in the Naïm manual are kind of vague to me. I would need ‘idiot proof’ instructions I guess. Please help.

Oops! Started off wrong. Unit is switched on… of course…

When you depress the display button on the remote, the chosen input indicators toggle on and off, but the light on the volume knob remains constantly off. Not such a big deal since the sound is still spot on for my tastes.

Please follow the instructions to the letter:

Step 1: press PRE button only (press once)
Step 2: press DISP button only (press once) - this will either illuminate or extinguish all the lights on the front (except for the logo)

PROG and PRE buttons are not the same :slight_smile:

It could be a break in the wiring to the LED (if it gets bound up on the shaft it can get caught - has the knob ever been removed?), or of course it could just be that the LED has failed. Your best bet is to contact your Naim dealer or the distributor so they can take a look for you.

Adam: Thanks for your suggestion. I did the pre-disp upon reading your first post. Nothing different happened. Then I went to page E23 in manual which suggested to hold ‘prog’ and ‘disp’ to restore defaults. No. change…
Richard: looks like the LED has failed. I should have some spares lying around. Hope I have a white one left. I have lots of blue ones. Also have tiny heat shrink tubing. Before I retired I worked for Raychem, the inventors of heat shrink.
Will let you know how it turns out.
Any other suggestions will be welcome. Thank you both for your help. Much appreciated.

As it changed the position it lit up (see OP’s first post) my money is on a broken wire or solder joint as per Richard’s suggestion, rather than a failed LED.


We got a winner! : David!
Gently pried the knob off and found that with time, one of the wires feeders no the LED had broken at the solder joint. A little speck of WBT solder and it was fixed! Problem solved.
Thank-you all. Saved me from risking be taken for a ride, which is all too common today unfortunately.
Thanks again!

1 Like

To be fair, I think Richard gets to share the prize because his mention of wiring made me think about solder joints. Anyway I’m glad it’s fixed.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.