ND5 XS2 connection

When it works, and most of the time it does, I love it. But every so often it throws a hissy fit and becomes invisible to the app. Tonight was supposed to be a celebration, spent listening to music, but instead I have spent hours on my hands and knees trying to get the bl**dy thing to work. Worked fine for half an hour but now the app can’t see it. But it can see the MuSo in another room fine. Have rebooted everything, reset the Naim, tried to set it up as new (“an unexpected error has occurred”): nothing works. This is an expensive piece of kit and it ought not to do this. Rant over.

Have you contacted support? Have you contacted your dealer?

Sounds like a network issue, but instead of ranting on this forum, you better reach out to Naim customer support.

I agree that it’s a network issue, probably an IP Address conflict.
First be sure the router and all devises are set to DHCP, then power everything off.
Wait 5 mins so the ISP system has time to know you’re off line.
Restart the router first, let it finish the process, then one at a time restarts the other stuff.

1 Like

Thank You. DHCP is enabled. Yesterday a router & streamer reboot didn’t work. Today it did. Go figure? It was helpful to know that I was trying the correct things, encouraged me to persevere (networks are a closed book to me). Thanks again.

1 Like

You have my sympathy. This happened to me last year, with some Naim boxes disappeared and others remaining visible. It all started when I bought a new switch. So I changed switches back but it still happened. Sometimes I could do nothing to get it working despite rebooting everything in the right order. It drove me potty. Sometimes it conked out in the evening but was fine the next morning, with me doing nothing at all. I thought it was a router issue so sent it back for a refund and got a different one. The problem has happened once since, but touch wood it’s ok. I believe it’s a discovery issue, and I know Naim have been working hard on this aspect. They were very helpful to me when it was all happening. If you continue to have problems it’s definitely worth getting in touch with them.

Fingers crossed!!


I’ve had this or a similar problem once, it turned out to be an IP Address problem, not helped I suspect by having turned on iPad wifi Private IP Address at some point. I found it when examining the IP’s listed in the BT Hub app, I saw I had 2x IP numbers for the iPad.
Easy fix, but it took 2 attempts of IPS off line time (5 mins) to clear the bad link.

1 Like

Thanks Everybody; it is reassuring to hear that this is a known ‘thing’.

This bastard is a bit picky. Just give him a proper router or cable. It does not like bridges, switches, extenders, etc. Say Tp-link archer a8 would be fine.
For myself I’v found that any glitch with the network or at isp will definitely break the streame. In such case I need either to reboot it or even factory reset. Hopefully, I reset it once a year.

1 Like

??? If they are done properly, I don’t see why not ???

1 Like

Because people just say stuff on forums on the internet. Of course it plays nice if your network is configured properly. And that’s where the problem is to be found 99.9 times out of a 100, but it easier to blame the switch, bridge etc.

He’s not ranting.

If done properly, it will certainly work fine.

From my experience, the Naim streamer is always the only one that refuses to tolerate issues. For instance, a dozen or two devices work perfectly.
Of course, this is caused by changes in the network. However, all network devices should be able to withstand such changes.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.