ND5 XS2 problem

I’m looking for some help. I cam home this evening to find the green power light on the streamer flashing and nothing from the LED. It flashes 3 times then a pause, 4 times and then a pause, then 9 times and a pause, then back around and on and on in the same cycle. The logo light is not lighted. The streamer is not seen by the app.

I’ve tried everything from powering down, leaving unpowered for 10 mins and re-starting, shutting down and then re-powering the whole system, rebooting the router (it is connected via cable), attempting factory reset (which makes no difference), and I am now at a loss.

Any information gratefully received.

I’m assuming by factory reset, you mean poking the little “SIM card” tool in the reset hole too n the back?
If that’s not solved it, I’d be getting s call in not Main, or s dealer.

Yes, poked 10 seconds with the SIM card poker. But this only works if the unit is turned on (apparently). It seems like the unit is in deep-sleep mode, but doesn’t wake when the power button is pressed. So unless the machine can be switched on, there is not possibility of re-set.

So, yes, maybe it’s back to the dealer.

Naim gear in my experience lasts and lasts. But I can’t believe my bad luck over the last year.

I have an original nait I bought in 1987 and it is still running plus other items bought over the decades that are all still fine.

However, last year I bought a HiCap for my SN1 and it failed after a few weeks. It was sent back, repaired and returned to me – except it still did not work – I sent it back and it was then replaced. All fine ever since.

I then bought a SN3 that failed after a few weeks and went back for repair (the right channel suddenly died). It was repaired and all fine since. And now the streamer. Man. I’m feeling a little despondent. Is it just my bad luck, or is Naim not what it once was?

The answer may involve “software”. Your old nait1 can be fixed with a soldering iron and some spares. Any device that is programmable leaves you in the hands of the programmer.
But at least Naim can fix your gear and it’s under warranty.


This morning, having left the unit un-powered all night, I tried one last time to wake it up, but this time, recognising that it appeared to be in some kind of semi-permanent deep-sleep mode, I thought perhaps a “jolt” might shake the bastard up, and so I held down the power button and then plugged the power cord into the mains. Et voilà, it immediately switched on with associated mechanical “click” that is typically heard when waking the streamer from the app. All seems fine.

So what was the solution? Unfortunately I didn’t firstly try powering up without the power button switched on, but I had done that multiple times last evening and to no avail. Was it the lengthy time spent in the unpowered state? Possibly, although last night I had left it unpowered for multiple periods of > 5 mins and on one occasion about 1 h. Maybe it was a combination of both. Or maybe it was the pixies what did it. As to what caused the problem in the first place, I have no idea. Must have been pixies.

Sticky relay?

Maybe. I’ve written to Naim Support and let’s see what they say. Maybe it should go back for a check in any case. It was such a strange fault – especially with the 3, 4, 9 cycling flashing power button (diagnostic?) – that I am hoping that Naim might have an answer.

1 Like

Leave it on and don’t let it go into standby?

Perhaps @NeilS would be able to tell you if this is a recognised fault code?

I’ve let it go in and out of standby mode several times this morning (as per the app settings) and all seems to be functioning as normal.

Sounds like teaching it a lesson has done the trick. Sending it back now will most likely result in " no fault found", especially if the fault was a sticky relay. And, I doubt the streamer logs faults in its memory.
So, what I’ll be doing with mine, is to exercise the relay a bit more often. I’ll switch mine off at the mains tonight!

That’s what i’d do. Keep those relays moving, assuming that’s whats caused it.

Thanks for all the ideas. I have it set so that it automatically goes to sleep after 20 mins (or there abouts) and then wakes when I click on the device within the app. As this happens probably twice per day, doesn’t this mean that the relay is activated twice per day? Is there another relay that gets exercised when the mains is connected / de-connected?

Not sure but that’s how i have mine. Goes into standby after twenty minutes. If i finish a session i command a standby via the app until the next time. Never had any problems with both my ND5 XS 2 & NDX 2. I don’t switch it off (unplug) at the wall unless i’m resetting the network, moving things around or if there is an electrical storm near by.

Thanks Stephen. This is effectively as I do.

I think the relay we are trying to exercise may not be deenergised when going into standby? Any thoughts?

If you go into settings >> other settings and click server mode off then i think we are talking about that same relay. You should now hear a positive click when going into standby mode via the app - assuming of course that this was the original problem to begin with?

If i was pbrain i would just continue to use the unit as he normally does until it happens again, in which case i would then leave it locked up, box it up and have it looked at.

Fair point. No point having to work around an issue when you have s five year warranty. As per another post, that’s why we buy Naim.

1 Like

Hi pbrain,

Fault code 3-4-9 indicates that a problem was detected with one of the I2C data buses, as to what may have caused it? A tricky one, it could be either an intermittent connection on one of the internal interconnecting ribbons, or the s/w had its knickers in a twist.
As Stephen suggests, I would advise keeping a close eye on it, try a factory reset using the rear pinhole now it is up & running. If it exhibits the fault again, pop it straight back to your dealer.


Hi Neil

Thank you for this enlightenment. I figured 3-4-9 had to be diagnostic of something!

I activated the re-set this morning and all is still functioning properly. Fingers crossed that it stays this way.