ND5 XS2 vent

After 3 years I’m getting sooo fed up with seeing this!

I used to get that fairly regularly until I upgraded to a mesh wifi solution. Since that change, streamer and app have been rock solid


I’d suggest you contact support@naimaudio.com - they can run through some network diagnostics with you. You can also phone them on T: +44 (0) 1722 443405

Hours of service are Mon-Fri 9:30am-5:30pm GMT/BST

I had similar issues. I changed to a newer router, it was a little better. I have since added a tp link mesh system……rock solid around the house, no issue with finding Naim equipment via the App. Wish i had done it sooner.

Yeah, this seems one of the cases where “it’s your network” is most likely the appropriate answer to what first seemed to be an app/unit problem

My Muso does the same now. It’s connected by cable to the router, the wifi is on the same router but suddenly the app on the Android phone can’t find the Muso. It can find the ND555 no bother, and the app on the iPad shows both. It’s frustrating, after never having any issues at all with all this stuff.

Have rebooted everything, reinstalled the app. No improvement…

It shouldn’t be affected by it, as it’s hard-wired… but are you on BT?

It might be your phone switching wifi networks on you.

This happened to me all of the time - but it was a function of having multiple wireless networks in my building. If I went to the kitchen to make a coffee my iphone would switch to my guest network. The signal is strong enough that my phone wouldn’t switch back to my office network when I came back.

I solved it by ‘forgetting’ the guest network on my phone.

It may be related to a more general issue in a vulnerability discovered recently which effects a wide range of equipment that utilises WiFi.

As a result of the industry as a whole looking at updates to resolve this it may be that various equipment you own will be in the process of being updated to resolve these identified issues, the same potentially applies to the WiFi drivers used in Naim products.

Further information is available at:

Check for updates and apply them frequently, ensuring you are using the latest stable releases available for your products, not all equipment will update itself automatically so do check manually where required.

Hope that helps, I’m sure it’ll settle down once the silicon vendors get patches out to ODM’s in the coming weeks.

Yes, on BT, and on a BT Smart Hub 2 but as you say being hardwired it shouldn’t make a difference. I’m not disabling the 5GHz band just to see the Muso on the phone.

Thanks for the nudge tho. I’m sure I saw something about this recently with a link to a BT forum where a fix was on offer / in the offing. Will check later.


Edit: the iPad is oblivious to the Muso too now. Good job it’s basically a radio in the dining room with presets already set up.

Thanks too, but I already have to check that routinely; the mesh network I installed makes the app (iPad and phone) lose Asset on the Pi so I have to remember to check that the iPad is on the base wifi not the mesh to use the NAS.

BT are offering fixes direct, if you contact them on their Forum. I would urge this, as the BT bug could be causing all kinds of issues. I use BT myself, but long ago learned not to rely on their routers - zero problems with multiple Naim units on wi-fi since.


Thanks Clare. That was the link. :+1:

A lot of sample instances and good advice here.
I used to see that all of the time with my old NDX before I went wired connection. It was odd, because even though I started out streaming wifi-only, I had the same Google mesh system I have now and would still get this dreaded screen. I couldn’t take the phone out of the room at any time, otherwise it would revert to this when I got back and I had to go through the screen prompts like clockwork to get the unit to ‘see’ the network.

With my ND5 XS2, I no longer get this—wired or wireless (though I never listen with wifi, just use the app). I can leave the house with my phone and come back after hours and my Internet radio keeps playing and ‘catches up’ to the current track when I enter the room.

If applicable to you, the comment to watch for your phone switching networks is something to watch, for sure. Mine rarely does this; and if it does it’s because I was fidgeting with something in the networking room (switching DC or power cables, etc.). As has been pointed out, though, a good mesh system or sorting out how your network is connected should remedy the problem. For me, it was a lot of trial and error, but now it is as solid and sorted as it can get (knock on wood).

It would help with a little more context. Are you utilizing an Ethernet connection or strictly wifi? Do you even have a mesh system? What does your networking component connections look like? I bet the forum members can set this straight with a little more detail.

It’s always worth checking the obvious…

Based on thinking it through, that a wired Muso wouldn’t be affected by BT’s failings, I’ve just clambered up to check the switch on top of the bookcase which feeds the PC, work laptop, phone booster and Muso. In the middle of the line of ethernet leads and flickering LEDs on the back of the switch was a duff one - no lights but the cable apparently in place. I reseated it with a little push and the radio on the Muso went off momentarily, then all the LEDs lit up and Radio 2 returned.

After rebooting both phone and iPad, both are now showing the Muso in the rooms screen.

So there you go - you might think your Muso is wired but it may be falling back to the wireless config that you forgot you’d ever done.


Glad I flagged up the BT point now! Even better that you’ve got it sorted.


Couple of pieces of advice:

Always wire where possible!

Use your own access point rather than the one built in to the BT or other router.

Use your own router! A lot of people forget that most ISPs can be used by any router. There are a few odd cases like Sky where they insist you use theirs. Buying a decent commercial grade router can pay real dividends.

For what it’s worth I’ve a Ubiquiti Edgerouter and two UniFi access points. Not quite plug and play to set up but absolutely rock solid.

1 Like

When I moved to BT FTTP last year I asked on here if there were any suggestions for using a better router; the consensus was that the BT Smart Hub is one of the better routers available and scores well in Which and other tests.

When you say yours pays real dividends, what specifically are you referring to?


I moved recently from Virgin cable to BT VDSL. I had my Virgin router setup as a bridged modem, added my own Router and seperate WiFi access points and infrastructure.
The BT supplied residential router (Smart Hub 2 in my case) no longer allows a bridged modem configuration so I simply replaced it with a Draytek Vigor VDSL modem and setup the same router (Ubiquiti Edgerouter) and WiFi equipment (Ruckus AP’s).
This provides a higher level of flexibility and configurability beyond that possible with the all in one BT router.

Ah; you are running 2 WiFi in parallel? That’s asking for trouble, IMHO.
(Unless you do so for different purposes: internal, guest, IoT, …).
Typically you switch off the access point in your router, when adding an additional mesh setup.

If you cannot reach some devices from your mesh, then something in the connection/setup is wrong. (Like running the mesh in routed instead of switched mode, the mesh being connected to the guest network of the router, some firewall beim active, …k