ND555 Firmware 3.7.1 Help

I have updated the Firmware of my ND555 on multiple occasions without issue.

However, when I tried to update to the latest 3.7.1 Firmware, the screen displays " Firmware Update,downloading firmware"

I have rebooted both the Sky 203 router and Melco switch, however I am unable to connect to the ND555 using either the IOS or Android app.

I also tried a neighbour’s Sky 203 router, same issue.

Obviously, I have left the ND555 powered on.

Any suggestions would be most appreciated?

One thing to be aware of is that there is a 15 min ‘lockout’ from start of upgrade from the App and the App-end - the App will not be able to connect until 15 mins elapsed …this had caused me ‘concern’ in past until I was told. Later versions may perhaps shorten or remove the delay.

So do let it sit in the system for more than that time before looking to another problem.

Then try another instance of the App installed on another device - does that connect, or are both not connecting?


It’s ok to turn the power off and try again because the ND555 keeps a copy of the last successful firmware and boots up with that.

I would turn the power off completely (unplug the PS from the mains or switch off at the mains plug or pull out the mains lead to the PS, for 15 minutes or so and then try again.

Hi DB,

Many thanks for your suggestions.

I have retried to download the firmware using an iPad Pro. When approximately 80 % of the firmware has downloaded which took 10 minutes, the display reverts back to the beginning.

The same thing happens if I tried the Android App on a Samsung Note 20 Ultra.

I have updated the Firmware ontwo Nova’s and an Atom without any problems?

Hi David,

Thanks very much for your advice.

I will try it and let you know how I get on.

It’s not the device that starts the download that matters. With the new platform you can start it with any device and then it just gets on with it. This is different to the series 1 Muso and Qb.

So using a different phone or tablet to start it off will make no difference at all.

If you remove the power, wait, restore the power after 15 mins and let it start up and then trigger the update and it’s still not updating then I would leave it until tomorrow when the Naim guys are back. If you are stuck with no music, then I suggest you do a factory reset.

Hi David and DB,

Many thanks again for your suggestions.

Unfortunately once the Firmware reaches approximately 80% the same issue recurs.

I will take your advice to contact Naim support tomorrow. I am able to stream music from both Qobuz and Tidal.

However for some reason neither my Melco N10 or UnitiServe is visible on the network?

Thanks again.

Did you try turning everything off, restarting your router and then when it’s fully restarted, turn on the ND555, Melco and Unitiserve?

If all three aren’t working, it really feels like a network problem to me.

Hi David,

I just retried powering down everything including the Sky router, Melco switch etc.

I restarted all the equipment as per your suggestion. Unfortunately, same result. Firmware downloads to approximately 80% then nothing.

I have a Marantz SACD 30N in another system. Absolutely no difficulties finding both servers with the Marantz?

I will try to contact Naim support tomorrow and I will let you both know how I get on.

Thanks again for your and DB suggestions.

Hi there.

I don’t know if this will help but I had a situation that sounds very similar to yours with a beta firmware update this weekend. I was at a loss and tried everything I could think of including removing power and factory reset but nothing got the streamer (NDX2) out of its half updated, non-responsive setting.

Finally, after one more power up, with the Home Screen visible but not responsive, I tapped the power button briefly and it set about updating the firmware, rebooted and has been working perfectly since.

Definitely contact support but give the power button a quick push and see if it’s reproducible.

Any progress @decnaim?
Interested to see if our two issues had a similar resolution.

Good morning John,

Thanks very much for your advice. I tried your recommendation earlier and unbelievably, it worked👍

Thank you so much.

I’m experiencing an issue with the latest version of the Android app. It’s continuously crashing.

Have you experienced something similar?

Thanks to you,my ND555 is fully functioning again.I was worried that something significant had gone awry with my streamer. I’m very relieved and more importantly, profoundly grateful for your excellent advice :+1:

Good to hear it worked!
That means I should let the beta team know as none of the testers have come across our particular state before and it looks like something worth warning about.

Unfortunately I am using iOS so don’t have any expertise with the android app. The iOS app crashes from time to time. When it does I uninstall the app, turn the phone off and then restart and redownload so it may be worth giving it a try? Presumably it has only just started doing this with the latest version?

Could be worth a new thread to see if anyone else is having the same issues


I recently had the same issue with my ndx2.

In the end I simply had to unplug it as it was taking hours to complete it and couldn’t.

I plugged mine directly into the router, did a factory reset then upgraded the new firmware no issues at all took around ten mins

With the factory reset you will need to hold down play and input selector buttons (the 2 middle buttons on the front panel) whilst plugging into the mains. This was advised by Naim.

Kind regards,

Hi @STREAMER i am not sure if this is exactly the same as removing power didn’t fix it.

I have had a couple of incomplete updates in the early days that necessitated complete power downs before they completed. My one didn’t respond to that or to the factory reset process you described. I’m not sure if @decnaim ended up trying that or not.

I’m in the beta tester group so have been through a number of “unusual” states with updates and this one was a new one on me.

I don’t know what made me single press the power button and I’m not sure why it worked. I don’t see it anywhere in the advice from Naim.

I have passed it up the line to the Naim staff on the forum.

1 Like

Hope you get it sorted. Things like this are very frustrating to say the least.

Kind regards,

Hi John and Tony,

I tried the technique kindly recommended by david, alas no success. I also tried a factory reset, again no Joy.

When I followed John’s recommendation thankfully it worked. I was beginning to get worried!

Thanks very much John for passing on the findings to Naim. I have kept a screenshot of your instructions in case, I encounter difficulties with future firmware updates.

Thanks to DB, David,John and Tony for all your collective advice👍


Glad you got it sorted :slight_smile:

Kind regards,

Warning on this update. Since I updated I lost tha ability to read several of my local files through usb connection. Most of the issue relates to several of my Hi Res 24/192 flac which I cannot read any more. Some other 24/96 are affected as well but less so.

I have contacted naim support for help and possibly donwgrading to 3.6

Please wait before updating.

Do they contain characters like “&”?