NDS connectivity issues terrible since 4.8 upgrade

Would be very grateful for help regarding connectivity issues I’m having with my NDS, much worse since the 4.8 firmware update (but very annoying beforehand). I just use Tidal. Issues started about a year ago - would try to play an album on Naim app - no response apart from the ‘number of tracks’ flashing up on the screen as though things were going to happen but then no go. The NDS screen would say ‘connecting…’.

To cut to the case, the only way to get things working again is switching off/on the NDS/power supply - all sorted, every time. If I just turn off/on the router and ipad (leaving the nds on), when it comes to selecting the nds on ‘rooms’ with the ipad, a box saying ‘another app connected’ would pop up with no further go. I don’t know what this means as there’s nothing else going on apart from a laptop. Switching off the nds gets things going again.

This whole affair can happen out of the blue - either going to play something after the last listen a few days ago, or like today, simply changing albums - all stopped. This was happening about every 2 weeks and I was just living with it after getting confused by Naim advice, but since the firmware upgrade it’s gone beserk and occurs pretty much every day.

I’ve just got a brand new ipad with the latest ios for the firmware upgrade, everything has been completely shutdown and restarted with NDS factory reset. No other devices that I use on the network ever have an issue, including a cheap little JBL that I stream Tidal to. Is this an inherent NDS problem or could it be the router that it isn’t getting on with? I’m a right technophobe and have no idea what to do, except for getting the sledgehammer out. Many thanks.

Have you tried logging out and back into Tidal through the Naim app?

Hi Mike - no, haven’t tried that but will have a go. Cheers muchly.

1 Like

What is your router?

The Tidal logon / authentication protocol has changed and 4.8 addresses that IIRC.

Can I also check you are on the latest version of the Naim App - version 5.22.2?

Hi FR - the router is a generic provider one - no specific name on it (just the providers name). The provider replaced a previous one as a network upgrade - they’re supposed to be ok routers but maybe not enough??? Cheers.

1 Like

Hi Clare - yes, I’m on the latest App version (5.22.2). Thanks.

And you’ve logged out of TIDAL and back in again on Naim App, as suggested above?

Beyond that, could be router issues. Would start by trying a full router restart. We can go from there

1 Like

Hi Clare - sorry, but what’s a full router restart? I’ve turned everything off (tidal logout, ipad, router, nds) and started from scratch before. Cheers.

Sorry not to be clear: i meant your router. What model is it?

Probably SFR , Orange or Free. It’s impossible to change them for another brand model .
Is the Wifi working strong?
Is the internet tv working too?

Hi Clare - thanks so much for your perseverance! The router is one that was supplied by our service provider, Spark, in New Zealand, and it must be a combined modem/router as we only have one box (I tell you, I’m really stupid and should just be playing discs/vinyl). It’s an Arcadyan - well, it actually says ‘Spark Smart Modem’ on it but Arcadyan somewhere else (the firmware I guess). Cheers again.

1 Like

Hi FR - wifi seems ok but use pretty minimally just for laptop. I don’t watch tv (anymore!). The nds is wired only. Many thanks for your help.

So still problems?
You can write to Naim customer support. Mail adress in these pages.

Thanks for coming back. I’m going to loop in our resident Forum router expert @Simon-in-Suffolk to see if he has any ideas, as this is a new one on me!

I’d also suggest (if you haven’t done already) to call or email support@naimaudio.com - it may take a while for a response, but you’ll be in the queue in meantime.

One obvious question - is the wifi disabled on the NDS? Clear the password and unplug the antenna if not done already.
Wifi should disable when you plug in the ethernet on the NDS - but worth checking


1 Like

Hi Simon - thanks for the help. Looks like wireless off. Network settings > wireless not connected > wireless cannot be used while using wired connection (something along those lines). Kindest regards.

Thanks Clare. Apologies for the nuisance. 4.8 is sounding good.

1 Like

How did you get on with resetting your Tidal account?

If your Spark modem/router is getting on a bit, you should be able to get them to provide a new one free of charge.