NDS Not Powering Up

I purchased a used NDX. It arrived today and I cannot get it to power up. I tried several outlets around the house, checked the two fuses next to the mains connection, changed the batteries in the remote and connected ethernet in and digital out (to a DAC).

I tried using the Naim app and didn’t have any luck.

Am I missing something obvious?


Are you trying to stream Tidal ? Or from a Nas?
Did the Ndx appeared in the Naim app and did you choosed it ?

Make sure you have the external power supply blanking plug attached at the rear. Refer to the manual if this is unclear to you (also available from the naim website if it wasn’t included),
Best of luck


frenchrooster - stream Spotify. The NDX did not power up (blank screen), so the Naim app cannot see it.

1 Like

Timster - That was it! Makes total sense now. Particulary since Naim calls it a Link Plug. Thank you very much.

So all works now ?

Yes, it all works now. Thanks again for your help.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.