NDS problem: Another app connected disconnect other client and try again

Anyone else still getting this with a legacy streamer and Tidal? My firmware and app are latest versions.

Happens quite regularly and only way I’ve found to clear it is powercycle the NDS.

Really annoying

Are you running the Naim app on more than one device?

1 Like

I’m on a legacy streamer and only get that message when the Naim app is simultaneously open on my other device.

1 Like

Try to change the password of Tidal. Delete the app and install it again. May fix your issue

1 Like

I have it on both iphone and ipad but only use one at a time and it happens when the app isnt open on the other device. I’ll try deleting it completely from the ipad…

Strange. I no longer have a 1st gen streamer but I remember that you only had to close the app on one device in order to open it on another. No deleting, logging out or power cycling was necessary.


I’ve deleted the app from my ipad and shut it down. Tomorrow I’ll reboot the NDS and reinstall the Naim app on my iphone. And I’ll keep the ipad off for a while. That should at least help me to isolate whether the ipad is a factor or not. I’ll revert back with my findings…

Issue resolved after buying a ND5 XS2, added to the N272 now used as preamp. All suggested actions were tested and the problem stay, a bit $$$ to be able listening symphony without drop out but sounds good.

I see this very occasionally, (but I don’t use Tidal) and I have multiple instances of the app in the house, on at least four phones/tablets and copies of beta and release apps. And both legacy and new platform streamers.

My fix is just to stop and restart the app on the phone/tablet I see the message. Takes a few seconds. No need to restart streamers or delete anything.

1 Like

Had exactly same issue with my ipad (naim app) - it was causing massive issues requiring nds rebooting. I couldn’t figure out what this ‘another app connected’ was, then found on my android phone the naim app (never used). I deleted it and problem solved. Really bizarre, to my simple mind. Unfortunately, Naim service couldn’t figure out the issue and was left high and dry for many many months…

Thanks all. I’ve been putting up with it for months but it can be a real mood killer. So this is what I’ve done to try and resolve it once and for all;

  1. Deleted Naim and Tidal from my iPad. iPad powered off and will remain so for the foreseeable
  2. Deleted Naim and Tidal from iPhone
  3. Powered off the NDS for a few minutes
  4. Changed my Tidal password on web browser
  5. Reinstalled Naim and Tidal on iPhone
  6. Up and running again

I’m 99.9% sure nothing else could be connecting other than the iPad, but the password change will make sure of it now.

I’ll give it a week and if the problem doesn’t resurface (it’s been happening multiple times daily) I’ll carefully bring the iPad back into play but being careful about ensuring the app is running on one device at a time. I’ll report back…

As I imply above, I think this is an occasional bug with the IOS app. It’s easily fixed - you just restart the app. I have found no need for anything else more dramatic.

Obviously if you have a copy of the app somewhere with “stay connected” ticked, then that is another matter.

I’ve tried restarting the app but got the same error message. I don’t think "stay connected’ was enabled on the iPad but it’s possible. Anyway a few hours listening this morning and so far so good :crossed_fingers:

1 Like

I get this message - started coming up a month or so ago.

I have an NDS.

  • I only have the app on one device my iPhone (that is the only device I have in the house).

  • I have turned on ‘Stay Connected’ but some how it turns itself off!

My question is why do I get the message when I’m only running the app on one device and who is turning the ‘Stay Connected’ option off?

Since I made the changes yesterday the problem hasn’t recurred, which is very promising given the frequency it was happening before.

I left my settings as default after reinstalling and the Stay Connected option is OFF. Not sure what it actually does, other than, er, stay connected! I didn’t have any drop outs yesterday and I was listening for hours. Presumably it stays connected when the device goes into lock mode?

PS in case it helps your predicament I’ll switch Stay Connected ON on my phone to see if it starts playing up again. I’ll let you know.

Stay Connected simply keeps your iOS device awake with the screen lit when you open the Naim app so that you have access to controls without having to mess around unlocking it every time. The downside being that it chews the battery.

I guess it’s possible that some unintended consequences of this could be causing your problem under the hood, but that’s something Naim’s software guys would need to investigate.

1 Like

I’ve had this same issue on the Android app with my NDX, on latest firmware etc. Have tried most of the fixes above. Interested to hear where you get to.

Still all good. I’m off work this week so system is playing a lot day and night. From memory it was happening at least every hour or so before.

I had the same issue on my 272. It is on the same home network as my Mu-so. I had to pull out the power cable of the Mu-so and then power it up again and the issue was solved.
My legacy streamer still plays up, however. The 272 vanishes from the naim app at times. It reappears when I power it down. I have to do this 2-3x a week.

Same problem here too. NDS latest upgrade, Ipad latest IOS.
Sometimes the app freezes too. Solving this with a restart of ipad.
Daily Tidal stop working. I been streaming with same set up for 6 years, but only last half year I got these issues. Very annoying.