hello friends
my NDX sn 362… doesn’t show the tidal app.
I did update the firmware to 4.6 (used to be 4.3) and also it shows 3D.

can you help please?


I believe you need to first install firmware 4.4 to get Tidal.

Also its not good to have a title line IN CAPITALS, its considered as shouting. Can you edit that please

sorry bout that… I didn’t notice.

regards the firmware, well, I jumped from 4.3 to 4.6
was that wrong?



Normally jumping firmware is not a problem, but I believe (& I might be wrong) that you need to go to v4.4 to load the Tidal links, then to v4.6.

I believe Mike is correct, you need 4.4 first. You can go back to 4.4 then load 4.6 again, so all is not lost.

Mike is right. If you are on 4.3 you have to do 4.4 before 4.6. It’s on the Naim website where you download the firmware updates.

Anyway no harm has been done. You can recover the situation by doing 4.4 now and then doing 4.6 again.


Do you think i can roll back the firmware?
Is there any way to do this?

No problem to roll back, load 4.4 & then reload 4.6

As Mike says you just now do the 4.4 update on top of 4.6 and then after that is all finished do the 4.6 again. Then it’s all back to normal.

This was the official Naim advice when we first discovered this problem just after the beta testing.


… & why we will miss the old forum beta records - as I did on this subject

hello my friends,

it all worked out, I did 4.4 and than 4.6 and it’s all back to normal.
thanks for your help


Thanks for letting us know it all worked

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.