NDX suddenly no display and no app connection

Hi there,
My NDX suddenly stopped after years of perfect operation.

The NAIM app now only says: Warning: Uniti gives no reaction. (why Uniti??) Also the display on the NDX is suddenly dark.
After pushing the input button multiple times I can still use the internal DAC (select a dig input) with perfect SQ. Also can I listen internetradio, but operation is in the blind since app AND display both do not work.

NDX is from 2013, in use by me since March 2019. At that point the latest firmware was installed. No updates we done or attempted since then.

I got recommended to have the display replaced and all SW updates done, that should solve it. However neither the display nor the SW updates should impact the app connection (I tend to read from the forum). So I would guess a different, an undelying cause (also since both problems started at the same moment), or am I wrong here?

App connection and display stopped at once in the middle of a normal listening session with Tidal. Several power cycles and factory resets (holding the stop key while powering-on) made no change. On the RC only the setup key gives any reaction: it lights up the central OK button and the 4 direction keys on the NDX.
NDX is connected via network cable, no network problems, no other NAIM products are in the house.

Hoping for a solution, love the sound through the NDX. Thanks.

Have you tried to restart your router, wait, then Ndx, then reinstall the app?

Thanks! obvious, but yes, I tried now all, even incl restart of phone :wink:
There is now a (mostly short) contact between app and NDX and it can play from Tidal and Spotify! But after a few minutes the app looses contact again (“cannot find rooms”), which can be solved by power cycling the NDX or sometimes by just waiting. Phone has good wifi signal strength and NDX has a solid cable directly to router.

Display stays dead, so that seems a diffent problem (amazing the 2 problems coincided). No updates possible without display, according to NAIM.
But I have some more confidence now to enter the repair path, though I hate to spend money on a display I normally never use …

1 Like

I encounter similar things recently. I have strong fiber , all wired, but something the server disappears. You can select « stay connected « in the app settings. It helps a bit.

What happens if you press the ‘disp’ button on the remote?

Actually that isn’t correct. You can do a firmware update without the display. But there are various setup things you can’t do without the display, so I think it would be worth getting that sorted. In any case I suspect there is another hardware fault with the NDX going on here.

I’ve used a dead screen for a few years now. Worked fine when I packed it up for a move. A week later, unboxed it was half dead and a month later totally dead.

But I noticed that in a pitch black room (not so much as moonlight or a stray LED from another unit), I can just make out the menu. Kind of black text on another shade of black background. Very faint but just about discernible. Slightest ambient light makes it impossible though.

display key RC has no effect
in my case the display just stopped, there was no fainting period (at least I haven’t seen it, then it must have been a short period)
I’ll try a pitch black room

Does anyone know WHY the NAIM monochrome displays faint/stop after some time? Maybe some conductive glue at the display came of? I’ve seen that happening in a series of PC monitors at work after a quite predictable period, irrelevant of use-time. My NDX is 9 years old now.

Also the weather has been extremely hot here last month, The NDX heats itself, is that to a fixed temperature, or to a number of degrees above ambiant?

Because they are OLED and this technology is prone to fading over time, especially by being exposed to sunlight/UV

It was never in direct sunlight, maybe that’s why it lasted 9 years.

Yeah but all sunlight contains UV, even indirect, and I suppose it accumulates

Similar issue (app does not see naim unit) suddenly happened with my Uniti 2… complete removal of naim app from iPhone then reinstall fixed it