NDX2 And Naim App Disconnects

I’ve had the NDX2 for a few weeks,
and it’s been fantastic.

Suddenly last couple days, I’m losing connection to it via the Naim app.

It can’t seem to find any rooms. Screenshot attached.

I re-added the NDX2, rebooted the NDX2 numerous times. It’ll work after some effort, but then will go back to that missing rooms screen.

Any ideas?


I’ve only posted on this forum once due to hostile replies. However…
I had the same problem.
The phone was finding two routers with a very strong signal, one mine (which is a wired connection) and another from a nearby neighbour. On opening the app, sometimes it connected to my router (so it worked) but usually to the other router so it didn’t work.

It was solved in settings where the neighbours router could be deleted. That was several months ago and no problems since.


Have you rebooted your router?

1 Like

Can you describe your network setup? Do you have any “Mains Powerlines”, WiFi extenders, second router, mesh etc?

Did some deep rebooting, turned all the wifi equipment off and back on again. Including all the satellites in my Wifi mesh, and of course the NDX2.

And… it worked. Strange, as I had zero other issues with the wifi. Naim app is fully functional again.

Nonetheless, the ol’ technology “turn it off and back on again” adage remains to be effective here.


My wifi equipment:
Verizon Fios modem, an Orbi Wifi Mesh router with two satellites.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.