NDX2 Firmware upgrade failing

I have tried multiple times to upgrade my NDX2 from 3.7.0 to 3.7.1 and it has failed each time. My app is up to date. I have tried from the app and the on screen menu.
It downloads and looks like it is going to work then just sits back and the firmware downloading screen and does not update.
At this point I can access the NDX2 from the app and play music. However I cannot power it off using the app or the top right power button on the NDX2.
I have to power down my 555DR PS to get the NDX2 to reset. It then works fine but with 3.7.0 firmware.

Any thoughts / advice?

Thanks Doug

Hi Doug

I would suggest trying these, then try update again:

Double-check you are on latest version of Naim App (2.22.2 for Android; 5.22.2 for Apple iOS)

Fully power down your phone/tablet running the Naim App and back up again (do not just close the App).

Fully power down your NDX2 - remove from mains power for 30 minutes.

While your NDX2 is powered down, restart your router.

Ensuring all on network is up and running and then reconnect your NDX2.

Try update from Naim App again

Thanks for the feedback everyone.
I have now upgraded. Not sure what the root cause was.
However factory reset and power down of NDX2 and router has worked.

Regards Doug


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.