Network Problem

I’m having a network issue which has me pulling my hair out, probably not entirely or even partly Naim related.

My home network is Sky Q router in the living room connected to master socket. Long CAT5 cable runs behind walls and over ceiling to a switch in the garage beside a patch panel. Throughout the house there are data points which have a corresponding socket in the patch panel. All hard wired network devices are connected to the data points and I’ve patched the corresponding socket in the patch panel to the switch. All had been working previously.

The Naim app has been updated automatically and my iPhone and new iPad are on latest iOS. I have an old iPad which is on a previous iOS.

My laptop is connected via ethernet and internet works. I use Control4 to operate some devices which seems to work when using the Control4 handsets.

The Naim app, however, is struggling to see the Atom. It usually sees the Qute in my bedroom but often freezes when I press on the Bedroom icon. When that does work it usually cannot see my uPnP when I press Servers and when it rarely does see uPnP it cannot see my music. I wasable to update the Atom firmware using the remote control and the front panel display. I switched the Atom to wireless and the app initially saw it but could not control it and now does not even see it. I’ve tried all three iOS control devices.

Interestingly when I open the my Philips Hue app (lighting) on my iPad it cannot connect to the bridge. I’ve tried several data points including ones that work with Control4. But it does work if I plug the bridge directly into the router or the switch and don’t use a data point. And I cannot open the Control4 app on my iPad either.

I’ve tried powering down the iPad, Atom, switch and router in that order and powering them back up in the opposite order.

Probably unrelated but I struggled to remove a cable from one of the data points a few weeks ago and the plastic socket came out from the plate a little. I’ve unscrewed it and the connections appear ok (although they are very fine) and there is plently of slack in the main cable. I don’t know whether the data points are connected as a circuit or individually and whether damage to one would affect the rest.

It almost seems as if the issue is with the iOS controlling device (except why does the iPad connect to the Philips bridge when plugged directly to the switch or router?). I ran out of time to do any further diagnostics this morning.

Very grateful for any thoughts.

My first port of call would be that sky router. Is it doing all wifi as well?

Looks like something in your home network is incorrectly applying IGMP group selection or group data… such as used by Philips Hue and Naim.
I suspect it’s your wifi bridge in your Sky Q router. Answer if the case is disable it and use a more reliable solution such as from Ubiquiti, or BT Whole Home.

Poor home network equipment will unfortunately be more likely trip up home automation apps which include the Naim app.

Hi, some thoughts and things I would try. You say your network was previously OK so unless you have changed things there is unlikely to be a fundamental problem to deal with.

If you have a damaged cable it should not affect anything other than the port / device it is on. Most switches simply ignore or disable a port with a shorted wire - unless you have a really old horrible switch! So, if you did damage an outlet that should not break your network.

If you turn the switch off and remove all the patch cables, put just the ones needed for Sky router, Atom and WiFI back in, if that works and the Naim app functions you can refit the rest bit by bit seeking the problem device. You will also get a clue from the switch LEDs. If they suddenly start flashing really fast you probably have a network loop, or maybe a faculty device, either way that will be the issue. Take that cable out again and see if the LEDs slow back to normal.


garyi - WiFi working perfectly.

Simon - thank you, but in words of less than two words English please.


-I-Dan - brilliant advice, will give that a go.

More for trouble shooting, than as a solution:
You can connect iOS devices via Ethernet (instead of WiFi); for an iPad Pro (with USB-C) you can directly use a USB-C-Ethernet connector; for devices with lightning ports, you need a lightning-to-USB and then USB-to-ethernet thingy (hoping the power supply via lightning is sufficient).

I understand, buying the connectors just for trouble shooting might be over the top; but a sure way to isolate issues with WiFi. (I agree with above statements, the the WiFi/router is more likely to be confused or missing features, than a plain switch. I assume, it runs as such, and not as a managed switch with more “advanced” features?)

Bruce, you say your wifi is working perfectly, as you are a network guy whats wrong with your network?

The problem is Sky Q Silver which I hardwired a few weeks ago because my Sky Q minis (which had worked perfectly for years wirelessly) kept on dropping off the network to the point where TV was unwatchable. With this disconnected everything else works. I’ve tried a different patch cable and a different socket on the switch but Not resolved and ran out of time this morning for more diagnostics. Will try a different Ethernet cable from the Sky Q Silver box but maybe I’ll need to go back to wireless and add some sort of booster.

Thanks for all advice.

Get a new wifi! and or an iPad! (There you go all less than two syllables other than wifi and ipad…)

I thought you might want to know why, otherwise why ask your very long question. Of course if you have searched back on the forum you will see many have had similar issues to you over the years and how they have solved it, funnily enough often in the ways I describe.

If you believe it’s a ‘network’ problem, then you should understand why in basic network terms… or how do you know where the problem is and why would you think it’s the ‘network’.

This is really simple given what you describe… anyway I have given you your likely solutions… please let the forum know which if any have worked for you.


Thank you very much Simon, much appreciated.

There’s endless duplication of material on the forum and no doubt the answer to my question is there in several different places. From a selfish perspective it’s usually much quicker to ask the question fresh than troll through previous threads. At one point I had considered whether my problem might have been caused by the Unite Firmware upgrade but that thread has almost a thousand replies!

Not sure what a new iPad would achieve. I have two iPads (one on latest iOS) and an iPhone and the issue remains regardless of control device. A change in a router setting or a different router sounds more plausible. Home networks are not my day job and I only need to understand them to the extent that allows me to successfully troubleshoot.

Thanks again.

As a matter of interest, what is the make of switch to which you have connected your Sky Q Silver box?

I too have an unusual problem when I hardwire my Sky Q Silver box to my network via a Cisco 2690 switch. As soon as I do this, my iPad air and Windows 10 laptop are unable to see my Roon Intel NUC over wi-fi. As soon as I disconnect the Sky Q silver box the problem disappears. The problem occurs when I connect the Sky Q box to either of my Cisco switches, but did and does not occur when I use a TP-Link consumer switch in place of the Cisco.

Incidentally, IGMP snooping is enabled on my Cisco switches.

Luckily for me, my Sky Q Silver box and my Sky Minis still work flawlessly over wireless.

Hi Bryce, you are welcome and good luck … and yes I know searching can be hard, hence why a response is helpful. But others have definitely had similar issues to you over the years.

It’s a bog standard 16 port Gigabit unmanaged Netgear switch.

I did have two Cisco 2960s (I assume 2690 was a typo), one between the Atom and the wall data point and one connected directly to my router with patch cables from my Atom, Qube, NAS drive and laptop. They were a bugger to get working, certainly not plug and play like the Netgear and then randomly stopped working at which point I lost the will to live and substituted the Netgear. This was all before hardwiring the Sky Q Silver box. They were meant to be factory reset but I lack the skill set to manage a switch. If anyone has an idiot’s guide to get them working I would be very grateful.

I also note the Chord Company are selling a premium switch (English Electric8). Not sure if anyone’s done a head to head with the 2960.

EDIT - actually an edit to my post 5 above this one. To avoid confusion I hardwired the Sky Q Silver box because when it lost its WiFi connection, the Sky Q minis stopped playing. The issue was with the Silver box’s WiFi and not the minis themselves which remain wirelessly connected. Hardwiring fixed the TV issue but has resulted in other problems.

The Cisco Catalyst switches will be plug and play, just like a basic unmanaged switch, if they are factory reset. My guess is that there’s an issue with the way Sky stuff interacts with them, as you’re certainly not the only person to have this problem. No harm in trying to reset your Ciscos just to be sure that’s not the issue, but it may not resolve your issue.

FWIW I would stick with switches from companies that specialise, rather than jumping on the ‘audiophile’ BS. Audio companies will happily sell you anything you are willing to buy.

It still sounds to me like the skyQ is a bit crap, but I have no experience of them. In your shoes I would consider with all that expensive hifi knocking around, ‘investing’ in some wifi access points. Such as from Ubiquiti.

Bear in mind that the best way of hooking up wifi access points is via ethernet.

There was an update to SkyQ firmware in july, did your issues being then?

Pretty sure it was more recent. Became aware of it earlier this week but hadn’t listened to streamed music since before my holiday towards the end of last month.

Interesting I have my Sky Q and it’s Satellite connected to Cisco 2960 and 3570 Catalyst switches and everything is fine… everything runs perfectly. All thevmulticast groups continue to work fine, and Sky Q layer 2 link to its satellite works fine… actually across two Cisco switches.
To see why you have an issue you need to see the sys log messages on the console port, or whatever you have setup, and the Cisco will tell you from its perspective any issue and why it might be closing down a port.

However I have a theory… on my SkyQ I have disabled the other access types … powerline and wifi and use Ethernet …
If you haven’t disabled, the SkyQ might be making a sort of network loop, which is usually an extremely bad thing to do, which if the Cisco detects will instantly shut down the port (On default setup) to protect your network… kind of sounds like what is happening, but the logging will confirm

Hi Simon,

Been away all day so have only just spotted your reply to my post.

Your suggestion sounds very plausible indeed. Just back from having a couple of dental implants so not really up for anything today, but I will look into this tomorrow.

Thanks for this.

1 Like

Putting Sky Q Silver on its own switch connected directly to the router has resolved the issue, but not really happy with this as a permanent solution as I had planned to have the two music streamers, NAS drive and PC on a dedicated switch but would now need three switches and my router has only two outputs.