New Core Backup Drive - don't know if I have a problem

I have been using a 5TB WD Passport USB drive to back up my 516GB (14,252 files) CD & downloads collection from my Core for the past 2 years or so with no problems at all.

Being a large capacity drive I have also used it to back up many other things such as my photo library.

It occurred to me that, should I need to reinstate my CD/download music collection to my Core it may fail due to all the other stuff on the drive (although I guess this is unlikely?).

I therefore purchased a 1TB WD Passport USB drive for the sole purpose of backing up the Core. I plugged the new drive straight into the Core &, via the Android app, it was recognised immediately & I was told it needed to be formatted in NTFS format. It then did that & gave the drive a name of NAIM-& a letter & some numbers (just as my original drive had).

I then proceeded to back up the entire contents of the Core & this went as it should have, taking about 6 hours before telling me the backup was complete & confirming the number of files.

Now for the problem. When I plug in the 5TB drive into my PC it appears as a normal external drive & shows all the files & folders on it & allows me to copy/paste etc. as normal.

However, when I connect the new 1TB drive to my PC it does not appear at all in the normal explorer window. A check with Disk Management (Windows 10) shows the drive is recognise by the computer but it just gives it a number & not the NAIM name allocated in the app. It also shows the drive as having a capacity of 931.48GB & free space available of 931.48GB, as if the drive were empty.

I have almost no doubt at all that all my CD/downloads are backed up properly on the drive & it would work properly if I needed to do a complete restore. However I would be reluctant to rely on it until I could see it in Windows & check for myself that all the files were actually there.

Could any Core or Windows experts give me any help as to why the disc is not appearing when connected to the PC & what I could try to get it to appear as it should.

Thank you in advance for any assistance.

1 Like

Your core has any internal drive that your music is stored? If yes then you need to leave it there as it is and just plug your new 1T to core with usb and back up there your collection.

That doesn’t sound right to me.

I suggest you do a power off restart of your Core and once it is back in the app, do another backup from scratch on that drive, including reformatting it. If you want to, you can cancel the backup after a couple of hundred files and then plug the drive into your PC and check the files are recognised. Then you can just restart the backup. It will add to the ones you already backed up.

Another approach would be again to restart the Core in case you have an odd service malfunction. Then plug in your backup drive and do another back up, on the drive that you hope has your backup, but without reformatting it. If everything is ok, the Core should see the drive, not suggest a format, start a new backup, then report that there are no files to backup (because they are already backed up).

Thanks for your help David.

I tried your suggestions but the result was the same. I noted each time I disconnected & reconnected the drive it asked me to format it which is clearly not right. I did a complete new full back up overnight & despite the app telling me all the file had been backed up this morning when I plugged the drive into my PC it would still not appear in Windows Explorer & disc management told me the drive was empty & would not let me do anything at all with it, even formatting.

The drive is clearly faulty. I suspect a faulty disc controller chip. I am returning it for a replacement.

As already stated, my existing 5TB back up disc is working fine & contains a full back up that can be viewed on my PC. I just wanted a smaller capacity disc exclusively for the Core back up.

Out of interest have you ran diskpart?

No, what is it?

Stick the drive back on windows the in the windows icon bottom write type diskpart and open it, then type list disk

You want to see your disk, it may be bigger than your other windows drives. Which ever disk it is, see if it has a little asterix under GPT.


Tried Diskpart & it worked on a spare USB drive I have but again, as per in Windows Disk Management,
the Passport drive did not respond to any commands.

The unit must be faulty & is presumably a faulty disk controller chip.

As stated earlier, it is being sent back for exchange.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.