New mu-so gen 2, No sound

Hello! This friday i did sell off all my Sonos products and bought a new naim mu-so gen 2 from a dealer.
Went home exited to start listening,
But i cant get any sound from it, i’ve tried bluetooth/hdmi Arc/wifi/internet radio.
I did reset it and the router but no luck,
Everything seems to work besides the sound, i always find the mu-so in the app, i can control it from my phone and i can control spotify from the mu-so.
So anyone have a clue or is it a faulty product?
Fyi i’ve been using sonos and audio pro & kef over wifi/bluetooth and they work just fine


When you attempt to play music does the track show as playing? i.e. the time count is incrementing.

Yes it is, the songs are playing, change volyme in both the phone and the speaker and they both interact,

It does seem very odd. Have you spoken to your dealer or wherever you purchased it from?

I have a Mu-so 2 and haven’t come across anything like this before.

Before delving into any more complex issues, could you have inadvertently hit the mute button on the app? It’s fairly small and easy enough to miss, in the bottom L corner at the end of the volume slider.

No mute on :frowning:

Yes, its strange, especially that i cant get any sound from any source

Strange. I just bought a Mu-so 2 a couple weeks ago (already had a Qb2, Atom, and NDX2).

I only ever use my Naim streaming devices as Roon endpoints, but they have all worked right away without issue. I would get the dealer involved. Maybe you have a faulty unit.

Seems like its a faulty unit…

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.