New phone can't find Room

So,I get a new work mobile ( Samsung a50).
But having put the naim app on it, it can’t find my streamer/room.
Yes, the a50 is connected to my wifi network, and yes personal phone ( Samsung s9) and old iPad mini find streamer/room as normal.
But odd. Any ideas?

Posted using new phone!

I have a memory that you have to allow the app to access location information while it is using the Naim app. The app doesn’t use the actual location information but it needs the permission to query the network. But I think that was Apple and I don’t know whether it affected Android too…
Best

David

Tried turning location services off. Still no luck. Just says the app can’t find any rooms. Strange as the nd5xs2 is clearly on and controllable via another device. And the new phone is connected to my network via the wifi.

Very odd. There will be a simple answer to this I bet.

You need location services on, not off!

I think someone who is more Android-savvy than me needs to help here.

Are you completely certain it’s the same WiFi network? Like totally totally certain?

Best

David

There is only 1 wifi network to connect to. No extenders, and only the 5Ghz. The nd5xs2 is hardwired direct to the router.
Even rebooted both, but it still does not find the room/nd5xs2.

Ok… it sounds like the dreaded Android /SSDP driver issue.
Unfortunately if the case it looks as if you might need a different client such as your old phone or Apple device.
One other thing to try … does your wifi have a setting for IGMP snooping? If so try disabling…
This may make your wifi inefficient but may make Room discovery pop into life on your new phone.

have you tried adding it via its ip?

Have you selected the correct Samsung? I ask this as I have sometimes downloaded an app via Google Play but inadvertently selected my old Samsung S6 instead of my current S9. I thought whatever app it was had not installed, but it was my error.

I am not sure how you would do that on the Naim app.

So now, it works. Done nothing different and the A50 can now drive the ND5xs2.
How odd?
Thanks for all your help. I’ll see how this goes.

Good stuff… unfortunately Android and SSDP is rather plagued… don’t touch anything now :grinning:

Where it can’t find it you can click add top right then at the bottom is manually add address

Ahh yes thanks I had to scroll the screen up to see it