New router connection issue

Hi all, sorry if this is old hat but….
I’ve just changed broadband providers (was with Sky, changed to Plusnet). All comparatively painless except that my Naim app (IOS) cannot find my Muso QB over Wi-Fi. Tried all the usual (turning everything off etc) and the app shows the new network on the failed search info. If I plug the QB into the router via Ethernet, all is well and working. If I then unplug the cable, the app can’t find the QB (even though it is sat at the side of the router.
What am I missing here?, any help gratefully accepted.
Many thanks

Might be worth uninstalling and then reinstalling the app ?

Have you set the Qb up for the new WiFi?

Hi David,
How would I do that ?, would it be via the new model route on the app?
Hi Si, yes I did try that, no luck

If you have all your house wifi & ethernet devices & the router set for DHCP, the router does it all.

Have you deleted the old network in your QB and set up the new one with the Plusnet password. I presume you have changed routers?

He has to have it set with the right (new) SSID and password Mike!

OK David (thanks)
SSID should have prompts
Is the password a Qb thing?
I don’t have a Qb, it sounds like setting up TV’s, all need passwords in set up, but they have setup guide screens.

No not a Qb thing Mike! If you want to connect anything to any WiFi network, you have to put in the SSID (usually select from a list of available networks) and the password.

As he changed his internet provider, they probably gave him a new router/WAP and that will have a different SSID to the old one. It will have a new password. The Qb will sit looking for the old network unless it’s told about the new one.

You know all that stuff…

You have to tell the Qb about the new network, which means setting it up again. But you don’t have to do that with Ethernet cable. That just works.

It’s explained here in the user manual.

Or do what I do; keep the old ssid and password and put that on the new router/WiFi adapters etc. fewer things to update.
My Aruba kit thinks it’s BT. We’re not even with BT anymore. Doesn’t matter, it’s just an id and password.


Yes I do that too. It’s a good plan.

Hi all, sorry for the delay in reply. Followed the reset advice and all is now well over Wi-Fi. Many thanks to all for your help and advice.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.