No sound on Mu-so when streaming over Airplay

Hello Naim community

I struggle to play music streamed over Airplay 2 (iPhone, iPad, MacBook) on my Mu-so (1st gen.). The Mu-so is visible in the Airplay menu offered in the Music app on my device. The connection seems to work, I even can control playback on the wheel control on the Mu-so (play, pause, forward…). But the Mu-so does not play any sound. After a couple of seconds the playback on the Apple device stops and the Airplay connection to the Mu-so interrupts again.

Does anyone else know this problem? What can I do to solve that problem?
Firmware is updated. I also tried to disconnect the Mu-so and set it up again.

Thanks for any help!

1 Like


I can stream music from an iPad to my first generation MusoQB without encountering the problems you mention. Both iPad and Muso are on latest firmware, so I assume it’s Airplay 2 but not 100% sure of that. The Muso is wireless rather than wired. I assume you’ve been through the reboot everything routine.



Thanks, Roger, for your reply.

I know tried the Mu-so in a different network and that worked well. So it must have something to do with the network router. Probably it makes problem since updating to 1.8 and Airplay 2.

Will do some more testing with other routers then.

Hi Euphony, Did you get any resolution on this, as i seem to be having exactly the same problem. It connects to the Muso as an Airplay speaker but still No sound at all. All my Bluetooth connections work fine & so does Radio direct from NAIM App.

1 Like

I have used my Mac & my iPhone XR to stream via Airplay & neither works.

Have you checked that the volume level on your Airplay devices is not set too low.

Otherwise try rebooting all devices (inc. Mu-So) as well as the router, then try again. If still no joy and nobody else here has any good ideas you should contact naim support.

I would do as @Richard.Dane mentions. I’ve just played some music from the Tidal app and the Radio Paradise app via AirPlay to my Muso 1, all good here. iPod touch, 13.6.1 iOS.

This sounds like a network issue, so as already mentioned reboot your router but also check there is no firmware update for the router (or other network devices you have).

I had a odd issue with a Marantz MCR 603 with AirPlay and it turned out to be a software implementation problem of DLNA on a WD NAS. Turning off DLNA in the NAS fixed the issue!

So, check if any new network device has caused the issue.

Thanks for all the suggestions. I have tried to re boot everything & still No joy.

Airplay working fine on my Denon AVR & Apple TV, it’s just the MUSO, so i will head over to naim support.

Check your router first, some of them don’t support AirPlay2, maybe your Denon is AirPlay1 which could explain why this works.

Do you happen to have a Ubiquity AmpliFi router? I also have trouble with Airplay 2 in combination with the AmpliFi router and I have seen other posts about this as well. All my other Airplay 2 devices work fine btw.

I have exactly the same issue, connects but no volume. Previously it worked fine. I can stream to Amazon echo devices and a Marantz CR611 from my iPhone and iPad. All software is up to date, including my Fritzbox router. I have emailed Naim support, no response yet.
It’s good to read it’s no just me but this is any suggestions would be most welcome

I have found a solution and that is to turn off the private address switch on my wifi network on my iPhone/iPad. I get privacy warning messages often. Settings/wifi/fritzbox 7530 WK. (My router is a fritzbox)

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.