Pesky HDX backups.... Network issue?

It’s been a few years since I last set up a back-up on my HDX.
I’m trying to set up a new NAS drive (Synology DS120) to use as a back-up store.
n-Serve shows the drive to be “offline”.
If I try to “Force add” by entering the IP address, I get a pop-up showing this:

I am unable to “Force add” the NAS drive.
The NAS is visible on my Mac in finder, a scan of my network shows it is pingable and all seems to be OK.
I have re-entered the NAS username & password within n-Serve.
There is something, somewhere, stopping n-Serve from seeing this drive as online.
Any ideas?
I’m fast running out of patience after a whole morning trying to get it working.
Limited technical knowledge here.

Does the NAS have smb1 sharing enabled? The HDX needs it but the smb1 protocol is deprecated and most modern devices have it turned off by default

I can never get this stuff to work in N-Serve. Try the browser interface, which seems to do it OK for me.
The only trouble is that as Flash support is no more, you will need another workaround!

1 Like

Yes, I have enabled SMB1 on the NAS drive.

OK. The error seems to be a standard Windows socket error (WSANO_DATA 11004), the text message is listed (very technical) here:

Is the DNS setup correct on your router, i.e. any network names for the NAS and the HDX (and everything else on the network, to be sure) have the correct IP address associated with them?

I would think the DNS is set up correctly as my other Synology NAS drive appears as it should.
It’s this new one I can’t add.
According to my network scan using NetAnalizer, there are no IP conflicts. My HDX is on and the new NAS is

Thanks ChrisSU, I downloaded and installed the flash workaround but still had no joy using the web interface :frowning:

“I would think that” has cost people countless hours :wink:
No IP conflicts are good, but I’d still check that the names are right. (And if it was me I’d check everything on the router. Also a full reboot of the whole network. Might be a long shot but. )
Else, I have sadly no idea

1 Like

When you say “check the names are right” which names am I checking and where?

It took me a couple of tries before it worked, then it’s been fine ever since. Possibly just user error.

1 Like

Most likely your router has a local DNS service that will assign names to the IP addresses in your local network, so that the devices can also be reached by name and not just by IP address. Where exactly in the settings depends on the router model. It should be possible to delete them and re-assign them. If you use the IP addresses directly, the names should not matter, but clearly something is off and it’s the best I can think of.
(Edit: Hmm, maybe there is also some kind of routing issue.)
On the Windows error code page it says,

Valid name, no data record of requested type.
The requested name is valid and was found in the database, but it does not have the correct associated data being resolved for.
The usual example for this is a host name-to-address translation attempt (…) which uses the DNS (Domain Name Server). An MX record is returned but no A record—indicating the host itself exists, but is not directly reachable.

This is all beyond my capability to be honest. I tried accessing the router web interface (it’s a MikroTik router) but for reasons unknown, I can’t open it.
I’ve reached the end of my tether and ability, so I’ll have to call in (and pay for) our IT guru :frowning:

If you want him to set up your backup you’d better give him a copy of the manual to read as well!

In the meantime as you’re able to see the relevant folders (Music and Downloads) in your Mac Finder you could always copy them to a USB drive so that at least you have some sort of backup in place. (Better if you store FLAC in this case.)

1 Like

Another question! When you say you’re trying to add the NAS as a store, what exactly are you trying to add? Have you created and named a new empty folder on the NAS and tried to add that as a Network Share?

I have set up shares on the the NAS, one share called “Downloads” (for the obvious manually added files) and another share which I’ve called “HDX_Music_Backup4”. (I tried other names as well in case it didn’t like underscores)
That share is empty and I haven’t opened it on my Mac, so it shouldn’t contain any hidden files.
I also installed Asset on the NAS and have pointed it at the various music folders. That all shows fine on the Naim app when I look at it on my NDX2.
I really want to use this new NAS drive as the music source for our multi-room audio, reserving the HDX as the primary source of music for my main system.
The n_Serve client usually lists available shares but the new NAS appears as “offline”.
I’d like to promote the new NAS to be an HDX backup drive, so that it automatically receives anything newly ripped by the HDX.
That is how I’d set up my old Synology NAS but, that has been grinding slowly to a halt recently, hence buying the new one.

OK, in that case I think you really need to get into that browser interface as discussed earlier. As I said, I could never get this stuff set up using N-Serve even though it looks as though you should be able to.

I’m using the web browser interface now (thanks for the Adobe link) and although it shows the shared folder, it still says it’s offline.
I tried re-entering the username & password for the share and it’s saying “HostScan”.

Once HostScan completed, the share reverts to saying “Offline”.

What’s the year in the last scan date, 1753-01-01 is probably not right? :wink:
The grossly wrong time might be interfering in unexpected ways, software is often not bug-free in this regard

At least that’s one more hurdle you’ve passed!

I wonder if you might have missed something in the Synology folder setup process that is causing this to fail. In case you’re not aware of it, here’s a very old guide to the process which shows you what to do, step by step. The UI is obviously old, but most of it still applies so maybe worth working through it from scratch.

Naaaah! The HDX is ancient, that’s probably the last time Phil Harris logged into it and fixed it.

1 Like