Problem installing usb driver to do firmware update

I need to update my NDX to Firmware 4.8 however for some reason I am unable to get the USB driver to install. I’m using a Mac with Big Sur OS. I’ve followed the instructions and the patch is showing as successfully installed after giving permission for it to be accessed however when I check to make sure it’s there as per the Naim guidelines (about this mac - overview - usb) the CP2102 usb to uart bridge controller is not showing up under the usb device tree.

Has anyone else experienced this? Suggestions on how to get around this are appreciated.



Have you tried different COM ports?

@frenchrooster the cable I need to use is the mini to usb with the mini connected to the NDX and the USB to one of the ports on my Macbook. The issue seems to be that the driver for any USB isn’t being identified by my Macbook even though my Macbook says it was successfully installed when I ran the installed that I downloaded from the link provided by Naim.

Maybe @Mike-B should help here.

1 Like

Have tried looking for port with Mac connected to Streamer and streamer on?

thanks @nitrous I did but nothing showed.

…. not sure I qualify to help, I don’t use a Mac & it seems the problem is in that.


Thanks Mike. Maybe @ChrisSU uses a Mac and could help here?

1 Like

You need to read the instructions carefully!

You don’t need to install the driver if you are running Big Sur. You select the “usbserial-001” device in the updater as explained on page 2 of the instructions, unless your NDX doesn’t have the mini USB port.


It’s been a while since I’ve owned a 1st gen streamer so I’m not sure I can be of much help. Here’s a wild card suggestion though - is the USB cable connected, and are you sure it’s a data cable, not just a charging cable that supplies power only?

1 Like

@ChrisSU @davidhendon I think I have the problem solved and it was with the cable! I was using a mini usb cable that worked fine last week when I updated my Harmony remote but for some reason it wasn’t showing on the Mac when connected to the NDX. I tried to install without the driver and it never gave me the option to to choose another driver other than bluetooth. I swapped the cable and now it’s recognizing the driver. Interesting with cables they either work or not and this one took a fine time to crap out on me. Fingers crossed that’s the last hurdle I will have in the update. Thanks to all who responded to help me out. This forum is a fantastic place!


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.