Problem streaming Tidal

I have had a Uniti for many years now and have only used for direct playing of CD’s or streaming from my NAS. I have today tried to fire up TIDAL and have subscribed for a 90 day free trial. So far I have had zero luck of getting it to run on my Uniti. I have updated to the current firmware. I have Tidal available on my PC and Smartphone which works ok. I have tried to load Tidal going through the Naim control app., all to no avail. Any help / guidance would be appreciated.

Thanks

Do you have one of the very early Unitis with the 24/96 streaming board? If so it would need a hardware upgrade to support Tidal and various other services.

I bought this unit in 2012, don’t know how to define the streaming board, where would I find it?

By 2012 the 24/192 board had been introduced, so this may not be your problem, but to check:

Using the remote control/front panel display, go to Setup > Factory Settings > System Status
You should see a line that starts BC SW, then 3D… for a 24/192 streamer board.
If you see 1A… 2A… or 2D… you have the earlier streaming board, and will to have the later board installed by Naim in order to use Tidal.