Problem with Nova freezing with EE 4g router

I live in a rural location and have recently switched to an EE 4G router to improve my broadband speeds (increased from 10 Mbps to circa 60 Mbps). However I have increasingly had problems with my Nova maintaining a network connection that provides me with a reliable listening experience. Stations freeze, metadata doesn’t load or takes ages, screen keeps telling me my stream has stopped and fails to reconnect. I have tried Ethernet and WiFi connectivity to router but problem persists.Has anyone else experienced problems using Naim streamers with 4G and if so is there a solution? My old landline broadband via a BT Hub was far more stable but unfortunately I no longer have this option having left BT. Sky Q box doesn’t like 4G because of increased latency of 4G and I’m beginning to wonder whether there is a similar problem with the Nova. Having said that, my Apple TV devices seem to work pretty well. I really would appreciate help on this
Rob

Latency may well be an issue, as you suspect.

Use one of tne broadband speed checkers and see what your ping time is.

I have checked my results history on Speedtest and my current idle ping rate ranges between 28 ms to 40ms whereas my ping rate when using BT broadband via landline was typically around 10 ms.

That ping shouldn’t be problematic; mine is 23ms on BT on FTTC.

It might be ‘congestion’ on the network if lots of other users nearby. I’d have a word with EE and see what they have to say.

Another thought; are you using external aerials? Might be worth considering after you’ve spoken with EE.

Sorry I can’t be more helpful.

If you look at the ping figure on a speedtest app it will show you the time to a random server, I suspect probably in the UK. It will no doubt give you an indication of any delay caused by your ISP, but it won’t tell you the delay to an actual server used by Qobuz, Tidal, or any particular iRadio station. These could be anywhere in the world with multiple hops to reach them, so probably with a much longer round trip time.

I tried a 4G service a year or so ago for similar reasons to you. It was OK until peak evening times, when it ground to a complete halt. I cancelled the contract and stuck with the copper landline.

Thanks very much for your input. I understand what you are saying about the location of the servers and you are right ,all my Speedtest results are based on servers within 40 miles. What I don’t understand is why the BBC radio stations also suffer from the same problem on my Nova. Stations take an age to load or will not load at all. I also don’t understand why I can connect easily to Radio Paradise via their app on my IPad ( which I can then Airplay to the Nova without a problem) but not direct from the Nova. It has been suggested that slow loading and poor connectivity could be a bandwidth issue and I have to admit we do have quite a few connected devices - 2 smart tvs 2 Apple TVs, 2 iPads,2 iPhones, Sonos Beam, Denon AVR. Whereas the “idle” ping rate is 28-40 ms the “loaded” ping rate is typically around 500ms. I gather the latter figure takes into account the actual activity on my network from other devices. Does this sound like it could be contributing to the problem?

Kind of very unlikely to to do with latency, 4G latency is going to be pretty similar to VDSL latency. The more you use any link in terms of increased utilization the greater the latency (if you are measuring with ICMP aka ‘ping’ which is not that reliable for latency measurement if routing across internet)
Out of interest have you a mobile phone that you can tether to on 4G temporarily to see if that works ok fine.
If so that points to something with the router and or its signal/antenna or the Nova setup.
Not that it helps BT and EE are one of the same, it’s just you are now using a different broadband service type. FWIW if use a BT/EE Halo service it uses fixed link for the primary and 4G as the resilient backup to provide seamless connectivity… nothing wrong with using 4G per se, and 4G/5G is widely used as a broadband medium these days, and is often used for private WAN connections too using SDWAN or similar which are typically used for more complex and demanding applications.

Out of interest you haven’t tried to hardwire or over ride the DNS settings or any other parameter on the Nova have you? Check it is using DHCP, and does all your home network devices use DHCP. Check you have nothing ‘hard wired’ or ‘statically’ defined network settings.