Problems after 'spring clean'

My Arcam AVR850 has developed a fault and it on its way back to them for repair.

So, I thought … it’s time for my annual ‘spring clean’ when I strip down the system, remove all the dead spiders from the rats’ nest of cables etc.

Took all day today (it usually does). Those Naim boxes are heavy.

Put it back together. Then various problems became apparent.

First, my LP12 Radikal/Urika was playing up. Played OK, but the turntable wouldn’t stop rotating and the red light (or green light if using 45rpm) was flashing. Only way I could stop it was by switching off the Radikal.

Next I tried the NDS/555PSDR. No left channel. Moved Sarum toned array to a different input. Still no left channel. Rummaged around in my ‘bits box’ in the loft and managed to find another lead. Same results.

So, it looks like the LP12/Radikal and NDS will need to be fixed.

… life can be hard sometimes … :weary:

Think I’ll try one more thing before ringing Cymbiosis, though. I’ll try moving the LP12 input to the one I usually use for the NDS just to make sure that I don’t have 2 duff inputs on the 552. It will have to wait till tomorrow because SWMBO has just gone to bed.


Are you getting only one channel just on the NDS or on all sources? If the latter then, assuming you are using either NAP135s, a 300 or 500 maybe check you have the leads the right way round - Red band for Right channel (Ch 2), Green band for Left channel (Ch 1). Getting them wrong way around can give you just one working channel.


This has happened every time I have moved house … when will I learn?
At least when I put things back together recently I labelled the cables … just lost a ball bearing.

Radikal problem fixed. I spoke to Peter Swain, and discovered that I must have pushed the ‘button’ on the back of the Radikal. Released it, and all is well with the LP12 now.

As regards the NDS, I’ve been advised to check all the connections between the NDS and 555PS, in case power isn’t reaching the NDS correctly. Not looking forward to that, as it means dismantling the ‘power’ stack - the 555 PS being on the bottom level. Space is very restricted, so can’t do it without dismantling the stack. It’ll have to wait till much later today, as I have “grandad taxi” duties this afternoon and early evening.

All the inputs on the 552 give stereo if connected to another source (I just moved the LP12 lead to each of them in turn), so the problem must be NDS/555PS related.

Just noticed a scratch on the front panel of the NDS. I don’t think I did it, but the grandkids were round here last weekend, and I wasn’t supervising them all the time.

Oh that’s such a shame …I’m in a state of twitching neurosis whenever my niece comes round …and things get thrown around…you have to remember … accidents happen!!

I did a spring clean a few days ago, simplifying how I power my equipment - I always approach these things with a degree of trepidation. Hope the NDS proves to be a simple fix.

Last time I rebuilt I reversed the channels on the superline, it was an embarrassingly long time before I realised.

Well, I stripped down the system again, and carefully put it back together, treble-checking each connection was correct according to the manual and my self prepared diagrams. Connected the NDS using my Chord Sarum Tuned array lead.

This time the LP12 and my Korg MR2 played OK, but no sound at all from the NDS input (I have it plugged into DIN input 2). Tried my cheapo DIN lead and again no sound. Can’t seem to find any of my original Naim interconnects. Did my son-in-law acquire them when I gave him the NAC52 and NAP250?

Much head scratching, and then I went into my bits box and found a phono to DIN lead. Did the appropriate bit on the NDS analogue output setup, and it works perfectly.

So, I either have 2 duff DIN leads, or there is something wrong with the NDS DIN output socket.

I think I will have to see if I can find the transit screws for the NDS - god knows where they’ve got to.

Anyone know what size/gauge/type they are so I can source new ones if necessary?

My guitar teacher is not going to be very pleased with me tomorrow, because I have done absolutely zero practice because of this and other commitments.

Just got my Naim CDS down off the top of the wardrobe, and found a Naim interconnect!

Plugged it in, and working OK. How can I manage to have 2 duff leads? What makes it even more difficult to believe is that both failed in exactly the same way - initially no left channel, then no sound at all after stripping down and starting again.

Or could it just be because I went into NDS setup twice - first time to switch to phono output, second time to put it back to DIN? :thinking:

That’s always the dilemma with computers (aka NDS) - when troubleshooting you never can be 100% sure when software is being pesky :grinning:

Have you tried resetting the NDS and going from there?


Just did that now. Chord lead still no sound, but works OK with supplied Naim lead. I really should update the firmware in the NDS, but for now I will leave it alone. At least it’s working now!

I wonder if I can get the Chord Sarum lead repaired …

I’m sure Chord can repair their own cables. Probably best contact your supplying dealer and take it from there.

Sorry to hear of your difficulties. My experience with Chord is that their support and repair service is really excellent. If the cables are at fault, you’ll get first class service from them, they’re nice people to deal with, and no, I don’t work for them!

1 Like

I’ll be posting the Chord lead back to my dealer some time next week.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.