PSA: NDX BridgeCo fault codes 59 & 61 FIXED

Public Service Announcement (PSA)

The NDX that I acquired this summer started acting up a couple weeks ago, becoming sluggish to respond to network commands and eventually unresponsive requiring reboot after short periods of use. I suspect that recent change in weather and drop in humidity here in Canada made matters worse, because the streaming module eventually gave out completely and the display would present one of the following error codes upon power-up:

Fault 59 - BridgeCo signal stuck
Fault 61 - BridgeCo init fail

Once it reached this state no amount of power cycling or memory reset would bring it back.

Upon removing the cover (please don’t do this unless you have experience working with sensitive electronics) I discovered that the white ribbon cable connecting the streaming module to the main board was not seated properly, as shown in the picture.

I cleaned the contacts for the loose ribbon cable and reseated it. I avoided the temptation to touch anything else and put it back together. The streamer immediately regained responsiveness and has been stable since.

Problem solved!

7 Likes

How lucky (well unlucky it happened in the first place) were you. There’s no way I would be brave enough to remove the cover and touch anything, also I’m sure Naim would rather we didn’t.

However you saved yourself money time and probably lots of frustration. Top marks.

What a momentous occasion it was, lifting the solid chunk of machined aluminum away from the business end. I’ve never seen a lid like that (more like a sarcophagus) or that heavy. They should make some units with a transparent lid so everyone can see how artfully laid out the circuits are without upsetting the Naim gods.

I have to admit I wasn’t going in completely blind, since I had read about the potential for loose ribbon cables in another post somewhere. Darned if I was going to send my unit to Montreal outside warranty and pay someone to do just that. However if it had been a more serious (terminal) problem I would have.

In the factory there are some units with transparent lids for each model in the range. These are used as reference blueprints for manufacture.

I have same error message. Anything I could do without opening the NDS? Thanks

I have same error on my nds. Do you think I can try to open it and see of it is the same issue you had? I’m not an expert but I can try small fixes. Thx

Nothing you can do without opening it. Ensure you have a clear work area free of distractions and the correct screwdriver to remove the lid, and a safe place to rest it when removed. Also make sure your clothing and work surface do not carry static charge. The ribbon cables are held by fragile plastic connectors similar to those used in laptops and gaming consoles that you have to be careful with.

Use an ESD wrist strap or similar if you are going to open up the casing.

2 Likes

Thanks!

How did it go?

assistance guy was very kind.
it was simply a connector that was disconnected, they justo opened up the NDS, plugged the connector and re-closed, less than 50 euro. now I am enjoying the sound again ; )

thanks for asking!