Qb update problem

After many months of Qb drop out issues ( lengthy thread on previous forum)
I decided to find the time to engage with BT and try and rectify any possible issues with my Broadband…

After 8 phone calls… numerous resets, line refresh, tests and more tests…
3 house visits by various BT engineers over a course of 2 weeks, and upgrading to the new guaranteed BT package …
the 3rd engineer seemed to make some progress yesterday… with all devices connecting (although the QB took about 4 resets to eventually decide to work)

I was thinking that finally all had been resolved… ??

Only to find that now my wife cannot access the internet on her iPhone 02 network …

All other devices appear to be working fine??

Any suggestions appreciated ??? (before I head to a darkened room with a bottle of Woods) :grin:

So is your wife trying to connect to the internet using your WiFi or the O2 network? If the latter then it’s nothing to do with your WiFi.


The phone needs a WiFi connection, my wife can only txt and make calls…

I’m still not sure I understand. I think you are saying that your wife’s phone cannot connect to the internet unless it uses your WiFi?

If that is right, then there is either a problem with her phone or with O2’s mobile network. She should try restarting her iPhone. And also try it when it connects to a different O2 base station. In any case it’s nothing to do with BT or your WiFi.



I don’t really understand myself, but when the new router was connected my wife’s iPhone will not allow going on ebay, Amazon, facebook, … but is fine during shopping at the local Tesco 2 miles away…or visiting my daughter who lives 5 mins down the road.

The phone says it’s connected to home WiFi… but all you get is the spinning wheel and the message can’t find server

Try hitting ‘forget this network’ in the iPhone settings menu. Then restart the router. Then get the phone to connect again from scratch.

Hi ChrisSU, i have already tried that, also phone reset, ect ect … no joy yet

Oh well, enjoy the bottle of Woods :open_mouth:

1 Like

Interestingly it seems the problem has been resolved…

The BT Router address on my wife’s phone was incorrect…and has been manually corrected…

As I understand it all router address’s end in 254, my BT Router was displaying an address ending in 0.5?

I wish I understood the reason why…but I have no explanation…

IP addresses can end in any number from .1 to .254 and you shouldn’t usually have to worry about which number a device has been allocated. I suspect changer to your router have caused some temporary confusion, now sorted by the looks of it.

1 Like

I have always understood router address’s to end in 254… and would automatically connect to any devices using the same address…

I might add, although I have learnt a lot recently, I am no expert …

BT Hub addresses are set to “” by default. This is configurable but can’t be changed accidentally.
So should take you to the BT Hub router login page.

Perhaps BT give their routers an address ending in .254? Other ISPs seem to use .1. Either way, there are usually 254 addresses available and the point of a DHCP server (usually the one in your router) is to automatically allocate one of these numbers to any device you connect to it. When everything is working smoothly, you don’t need to take any notice of this, but occasionally there is a glitch, as you seem to have discovered. A router restart is often all it takes to correct it.

Interestingly the router was replaced twice, rebooting umpteen times…3 BT engineers…, it was only my Son-in-law that noticed…

and then change to router address had to be put in manually., it should just be automatic

When you say automatic I now suspect you do not mean the IP address of the the BT Hub…

I mean the router should automatically connect with your phone or device and the address on the phone or device should be the same address as the router …

The BT Hub router will have DHCP enabled by default. This allocates each device that requests it an IP address from it’s available list. If the requesting device hasn’t asked the router then requesting device may not have DHCP tuned on and therefore won’t connect automatically. The fact that you SIL had to put the Gateway IP address into the phone would suggest that DHCP is turned off on the phone.

As Guinnless says.

In fact no device on your network should have the same ip address as the router.


Interestingly DHPC was not turned off, the phone settings said it was connected to WiFi but a different router address … hence phone would not connect to internet until manually changing the router address on the phone…,. to me it makes no sense

It’s not normally possible to edit the Gateway IP when DHCP on the client (i.e. the phone) is enabled.