Qobus not recognised

Hi. I’m on a Qobus trial. My Atom streamer doesn’t recognise my Q account and says I’m using an invalid name or password which is not the case - the log-in and password work on other devices. That is when using the Qobus button on the Naim app menu. Am missing something?

I can also listen to Qobus by using the Q app on my phone and using Cast. In doing that am I missing out? - apart from it not being the best way to access Qobus on the Atom.

Thanks for any replies.

I think to remember that you have to log out on other devices first. You can restart your app also.

How many devices have you logged into Qobuz? If it’s more than your subscription level allows, you won’t be able to log in. Try logging out on any other devices and see what happens.

Perhaps is doesn’t recognise Qobus because it’s actually Qobuz…


I am logged concurrently into the Qobuz app and within the Naim app and within Roon on the phone and tablet. I don’t have Family.
I can’t play at the same time, but logged in should not be a problem

I logged out elsewhere and it’s not made any difference.

Agree - I have Qobuz on numerous devices including my Nova, iPads, iPhones etc on a single seat Sublime account. Never had to sign out on one to play on another - I think they used to allow two ‘seats’ for accounts before family subs arrived.

I don’t know really because don’t use Qobuz, neither Tidal. But remember some similar threads and responses.

Any foreign language or uncommon characters in the name and password? Could be an encoding issue that somehow mangles the credentials and what gets sent to Qobuz is not actually what you entered.

Yeah I don’t know, just saying that it is not a problem for me (nor was it with Tidal before Qobuz) and frankly I cannot imagine that is behaves that way. Imagine the uproar if every time you wanted to listen to Tidal/Qobuz on the phone when traveling, it told you that unfortunately you are still logged in through the Naim app at home.

Edit: as far as Tidal, the FAQ even says that you can use 1 device in online mode and 5 in offline mode (with pre-downloaded stuff) simultaneously

An old Qobuz article says “3 devices”

There is nothing current on their help pages that I can find.
I just tried to log into the web player too. So I am logged in on what I think are 5 devices:
Phone and tablet in Naim app, I guess this is one device as it is the NDX2
Q app on phone and tablet, 2 devices
Roon on phone and tablet, I guess 1 device
Laptop browser, 1 device

I started music streaming in Q app on tablet, phone, and browser. All 3 are playing

Something better to not find why, just log out all, switch off the router off then on, restart the streamer, restart the app, and it finally works.

5 minutes before, I copied and pasted similar threads above. But then I couldn’t write nothing on IPad. I had to switch it off and on to come back to normal working.

Problem solved and feel free to smirk. :blush: When I set up the Qobus account I was asked ‘what shall we call you’? I gave an answer and thought that to be my username. But no, apparently my username is my email address. Not sure what the point of the other name is, but who cares? It works. Thanks for being there folks.

1 Like

Jonathan, I think you’ll find the service is spelt Qobuz, as HH called out earlier… probably best to get right to avoid confusion.
I guess I could to look up something on Giggle, Fistbox or listen to my Nam amp many would know what I mean but not everyone.

Why Qobuz is so named… https://www.qobuz.com/gb-en/info/actualites/why-is-qobuz-called-qobuz174873. (Hint A Qobuz is apparently an asian two stringed horse hair violin used in shamanic rituals providing a richly harmonic other worldly sound)

1 Like

Just googled qobus and it get one to qobuz’s website. If it’s good enough for google, it’s good enough for the naim forum.

I wouldn’t get to hanged up about it.

1 Like

Earlier I was half-way into writing a posting to ask if you were absolutely sure you were entering the correct credentials. Then I scratched it, thinking it was too silly. Never again :slight_smile:

No… if genuine mistake then no problem what so ever, but HH already called it out in a polite and amusing manner and was ignored and persisted with . it’s like a slight arrogance… and disrespectful to the members…but I have said my piece…

BTW when I Google “Qobus” I get a correction query do I mean Qobuz… and if not a list of local QuickBus services… so evidently not totally ‘ good enough for Google’. :yawning_face:

1 Like

Hi, Suedkiez - yes I cheerfully admit to sometimes needing a basic steer in the right direction! So in my case at least you won’t cause any offence. :grin:

1 Like