Qobuz problems on a NDX2


I’ve been using the native Qobuz Naim app (IOS) since February, on a NDX2 streamer.

Even though the sound quality is very high, I do have problems with Qobuz

In the beginning, I encountered a few problems when reading a playlist (the NDX2 would stop playing after a few tracks).

The problem has now worsened; the NDX2 stops playing the playlist after each track

  • I never had such problems with Tidal
  • To my knowledge, I do not have any network problems (150 mbit/sec bandwith, and low latency)
  • The Ndx2 is connected by a copper wire to my LAN
  • I do not have dropouts in the middle of a track

Has anyone else the same problems with Qobuz ?

Thanks for your answers

Have you tried a full power off restart of your NDX2? So not just pressing the button on the front, but unplug the power, wait ten seconds and then plug it in again? Let it start up as usual.


1 Like

I already did a reset to factory settings, but it had no effect on my problem.
Besides this specific problem with Qobuz, everthing works fine with myNDX2 (Tidal, local uPnp server, internet radio,…).
Right now, I am really thinking about cancelling my Qobuz subscription, and going back to Tidal


Try to restart all, router first, wait, then Ndx2. I had similar problems and it worked for me. ( same problem but for Tidal in my case).
Installing the Naim app again can help.

I think ringing Naim support might be a good idea tomorrow then. They may know of an issue with Qobuz (there was a playlist issue just a couple of days ago).



This was the recent problem but on the Android app. Could well be that there is a connection though.

Tagging @tomvamos just in case.

I am located in Seattle, WA and have been using Qobuz since last February with my NDX 2 and have had no problems at all.

Have you logged out of Qobuz on all your computers and through the Naim App and then logged back on? Some folks have had a problem with to many open connections in the past.

I have been fortunate and have not experienced any issues with Qobuz with my NDX 2.

It should come back to normal very soon.
The OP should be patient. It would be sad to give up Qobuz as it sounds better than Tidal.

I had 3 open connections (NDX2/iPad/PC), closed all 3 connections and reconnected the NDX2 but it did not help.

I also tried to reinstall the NaimApp on my iPad; it did not help either

Other symptons

  • when the NDX2 finishes playing a track, I goes back to the first track of the playlist (but does not play it)
  • sometimes, the NDX automatically resumes the playlist after a few minutes, or a few hours …; in fact, quite an erratic bahaviour

Thx for your help


I have the ND5XS2 and a similar issue where the Qobuz selection (album or playlist) will stop after tracks and not automatically start the next one. Frustrating and unsolved as yet.

Don’t know if it’s a Neils territory, but apparently a problem with Qobuz on Naim app that several have. Just a message to you Richard. Thanks

It’s probably an issue for Naim tech support, but I’ll ping @Stevesky just in case there’s some other issue at play.


Hi @nca

If our support desk at support@naimaudio.com can’t resolve it, then email me at steve.harris(at)naimaudio.com and we’ll break down the problem. We know the solution 9n the ndx2 is stable, so this must be some network environmental or account related issue.

Best regards

Steve. Harris
Software Director
Naim Audio

1 Like


FYI : that was unexpected, but it looks like the latest NaimApp v5.17 (IOS) solves the Qobuz problem I’ve reported a few days ago (NDX2 stops playing after each track)
This is at least what I’m seeing from early tests.


Well … the problem is back. …
I’ve been able to play several tracks of the same album, just after the SW installation (did not happen for a few months) .
But now the exact same problem is back.
I do not have a clue on what is exacty happening.
I’ve created a ticket at Naim’s support

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.