This may have been raised before but I’ve not seen it.
I signed up for the free Qobuz sometime ago but due to problems with downloading at the time (which I believe was a Naim problem with the NDX2) I cancelled the trial.
The other day I started a full subscription with Qobuz. However on the Qobuz app I receive the subscription download but when I tried to download this on the NDX2 Qobuz I only received the free trial despite using the correct email and password. The only way I can receive the subscribed Qobuz download is through Chromecast which requires additional messing around and the sound breaks up on hi-res.
I think I really need to clear the NDX2 Qobuz input but have so far failed.
I wonder if anybody else has suffered this problem.
I’ve contacted Qobuz who’ve come back to me and are trying to resolve the problem. Naim acknowledged receipt of my query but have so far not come back. My dealer sent some advice but it did not work.
I’m beginning to get a bit p*ssed off with Naim’s after sales service.

In the Naim app, have you logged in to qobuz correctly? Go to settings/ input settings/ qobuz and maybe try logout then login again.

Apparently, from what i understood, you have to log out first in the Qobuz app, before logging Qobuz in the Naim app.
Eventually log out too, remove the Naim app and download it again.

I’ve tried it but still get the free trial screen.
I’ve tried to clear out the Qobuz on the NDX2 to no avail.

i know it sounds daft -but i found the initial probs i had with qobuz log-in were fixed by shutting down both muso and tablet & leaving it overnight. next morning everything was fine - another forum member found the same. worth a try

Tried it but still only the free trial screen. It did at least blank the Qobuz button on the NDX2.

You can run Qobuz on the Naim app and Qobuz app simultaneously. There is an overall limit on the number of devices you can run it on simultaneously though, so if you are running Qobuz elsewhere you may need to shut it down.

I’m running it through the Chromecast setting on the Naim app but hi res breaks up and there’s a lot of unnecessary faffing about compared to the Qobuz setting.
The free trial plays hi res ok on the Qobuz setting.

2 thoughts:
1 just let the free trial run on the naim app and when it finishes, log in with your paid account details.
2 I found like you that chromecast from the qobuz app does not handle high res. However when I used the bluetooth connection it worked fine. No idea why.

1 Like

I’ve now discovered the same thing and appear to be in a half way house.
Not full Qobuz but playing hi res through the Naim app.
No idea what’s happening but the SQ is excellent.

Thanks everybody for your suggestions. As you can see from my previous post I appear to be part way there and now waiting to see if the full app appears at the end of thirty days. Fingers crossed!

After playing hi res through the Qobuz setting on the Naim app for a couple of hours more album options and the Qobuz screen bar have appeared.
It seems taking all my Qobuz and Naim apps off all my iPads and phone and reinstalling them has sorted things.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.