Radio delay between NDX2 and Nova

Should I be surprised that when streaming radio (e.g. Radio Paradise) the timings are different on the two devices? What would be the reason for this?

Streams to different devices are not synchronised. If you want them to be, use multiroom (either Naim’s, AirPlay, Chromecast or Roon) and they should sync perfectly.

1 Like

Thanks. I just wondered what the reason was, technically speaking (I may regret asking that…)?

I get that with iplayer; try and watch bbc 1 live on a tv and an iPad perfectly in sync.
It will be down to buffer size differences etc between the 2 devices.
And that’s assuming that the rp server itself is able to stream perfectly in sync.

The buffer size on the Nova and NDX2 is the same. I think you’ll find that the issue lies upstream.

@JamesBKK I have different devices and listen to RP a great deal.
If as Chris has already commented, if I’m in adjoining rooms, then m-room avoids the difference.
I also asked this very question in the course of beta testing - unfortunately the search function hasn’t pointed onto that exchange - I will try later.

IIRC each device requests a stream from the radio host. So the timing is based on the request. It is not a single feed on which you “alight”. It that sense, FM radio falls into that latter category - each and every FM radio will be “in time”. That leads on to a different issue with say BBC, where there is a significant timing difference, between FM radio which is always “on time” - big ben being an example and Beeb via iRadio, which lags behind - it can be a minute.

To answer your original question, no surprise. Enjoy the music; hope that helps.

1 Like

@JamesBKK my searching has improved. This is the question I posed in September 2020.
While it was posted and responded to, on a beta testing thread, I don’t believe I am breaking any rules repeating the answer here, since it was raised as a thread drift. The answer courtesy of Stevesky was:

RE: Shift between two devices

This is because there are big buffers with no absolute time to say that a given point of audio from the server should be played at time x. So each device just grabs a pile of audio from the server and starts playing it.

Think of it like having two pints of beer being poured from the taps at the same time at the pub. One will be ready to drink before the other, even though they are being supplied from the same barrel. The person who gets their beer first has the head-start. When in multiroom mode the system ensures no one is given their beer first and there are strict rules on speed of drinking!

So there you have it - cheers!

1 Like

Naim’s built in multi room function in the app works well, but you need to group your devices to make it work. Roon is another great option. See the icon below, that’s multi room.

1 Like

I’m unclear by the reference to “group your devices”

On Naim’s product page for Muso (as an example), these are the steps Naim propose - I have substituted Muso for device, since the guide works for all streamer combinations.

  1. Touch the Naim app.
  2. Select the device you want to set as the master control unit.
  3. Select your preferred streaming audio source (E.g. iRadio).
  4. Touch Naim Radio.
  5. Touch the Playing bar.
  6. Touch the Multiroom icon.
  7. Select … another device on your network.
  8. Control the volume level of each device individually or as one with Group volume slider.


I don’t want to distract from the subject of the thread, but I have an issue using Multiroom and I don’t think it’s irrelevant. I have a Muso 2 and Muso QB1. If I play iRadio on the Muso2, I can use Multiroom to connect to the Muso QB which starts to play the same station and in sync. However, the sound on the QB fades in and out. If I try the connection the other way round - starting with iRadio open on the QB - Multiroom sees the Muso2 but cannot make the connection. Both Musos are on wifi so I suspect this may be the problem.

Any advice would be welcome.

Hi Clive, it’s easy to blame the network, unfortunately too often it is the route of many of such issues. It relates to discovery and multicast, not all routers deal with these equally well.
First suggestion is to power off each Naim device and then restart your router, wait 10mins + then restart each device and see if that helps.
The next best advice is to suggest the use of two patch cables, connecting your Muso2 and QB1 hard wired to your router. Patch cables are a few bob and length doesn’t matter so for the purpose of testing, you can get a cable long enough to reach an adjoing room for one device. You could try as an alternative, use a patch cable on Qb1 and wifi on Muso 2 - the later has improved wifi against the Qb1.
As a matter of interest, do you have mesh wifi (make?) and any SkyQ wifi?

Thanks SH - I suspect that hardwiring the Muso2 would be a significant help. I have a BT Hub2 router with one BT add on disc. I don’t know if the disc is equivalent to mesh wifi. In theory both Musos should pick up wifi from the router itself but either could theoretically be connecting to the disc which maybe could cause a problem. I’ll try turning off the disc and see if that makes a difference.

It should still work. I have a Muso Qb1 connecting via Wifi to the main router (over a surprising distance), a Nova connected via ethernet* to a wireless BT disc and an NDX2 connected direct to the router via ethernet.

I can multiroom from any device to any other device(s). e.g. Qb1 to Nova.

*Also works when not using ethernet but the ethernet cures an issue I had with the connection flicking between 2.4Ghz and 5Ghz.

Seems to work fine when I turn off the BT wifi extender disc.

So it also doesn’t matter if the taps were turned on at the same time either?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.