Red blinking led on Muso 1st gen

hello everyone,
i am at a loss as to what’s happening with my Muso 1st gen.
I recently moved home, went into a new apartment with a wifi that sucked but worked so so. I asked the landlord to increase the bandwidth with Vodafone, and they did while i was travelling for work.
I come back yesterday and find my Muso blinking red. I’ve tried a reset for 5mn option but it didn’t help.
I can make the led blink yellow after doing a 10 sec reset, but it doesn’t go anywhere. Sometimes, my app can find the Muso and tries to connect but the connection doesn’t establish…then it goes back to blinking red.
Is it possible to reinstall the firmware through the USB port?

I’m living now in Germany but bought the Muso in France like 5-6 years ago so not sure where i would have to turn to if I have to call for Naim’s help…?

Thanks for any help you can bring me :slight_smile:

Can you get a wired connection to set it up without relying on WiFi? Even temporarily.

Sorry to say that i am going to be the bringer of bad news because that blinking red led is not good news. When i had my first muso it got bricked during an update and when i took it to John Lewis i got a replacement and straight out the box this one had a blinking red led. I was told that it was faulty and had to be returned and then got a third replacement and to this day this one has been okay.

The blinking red LED may be a warning of a failure somewhere.

Have you been in contact with your dealer or with Naim support yet?

no, but thanks guys! how do i contact Naim support?

Here you go:

thank you, i’ll contact them now

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.