Red flashing light

I have mu so 2, this morning, since update my mu so don’t work. Initially the big controller kept flashing and the led light stayed blue. Done all recommendations like switching off Naim and wi fi completely and re boot, no difference. I then put pin in the hole next to light until blue light went out no lights at all for about a minute the a red flashing light comes on and the big dial light goes only half bright, after 1/2 hour the main dial light goes out but the led is still flashing red. I’ve tried everything on my iPad but can’t get any further than searching. I cannot access radio stations. The unit is only 13 months old. Any advise would be appreciated

Hello, how far away from the router is your Mu-so?
I had the exact same problem with my Mu-so gen 1 with the last update. So, I carried the Mu-so into the same room as the router and placed it right next to the router. It then completed the update.

1 Like

If moving Muso close to router doesn’t work then connect to router with an Ethernet cable. You don’t need this all the time, just while the update installs.

Thank you both for your advise which I tried both but still not working. I called the Naim hotline and explained all of the above. fortunately they know the significance of red flashing lights, unfortunately it means there is nothing I can do to make it work it will have to be returned to Naim for repairing. Fortunately it’s still within warranty so it won’t cost me anything.


I’m sorry about that, let’s hope you get it back in quick time.

Me to, I can’t get it back to shop where I bought it from until Friday then they will post it to naim so guestimate 3-4 weeks.

1 Like

I’m sorry to hear this. I hope that your Mu-So is fixed or replaced to your satisfaction. How frustrating,

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.