Request failed: bad gateway (502)

Has any other forum member had the above message when trying to access album information on the Naim app ?
Music plays from ripped CD’s. Tidal still works, just can’t read any of the album details.


Me too last night

Yup. Right now.

Me as well this morning.

All day today frowning_face:
Unfortunately the naim app increasingly looks, feels and operates in a very dated way compared to the competition.
I love the sound though and that’s what’s most important to me. However I definitely don’t feel I represent the majority of buyers.
Hopefully naim will sort it out.



I’ve had the same problem all day. If not resolved by the morning I’ll fire off an email to Naim Support, as I’m fairly certain they don’t monitor this forum for issues or complaints.

E-mail sent to Naim Support 5 minutes ago.

1 Like

Same issue here in the States as well - I just tried

I once had a 502 bad gateway error on a computer, and I vaguely remember that it turned out to be a problem with a remote server. I don’t recall the exact details, but that might suggest that your issue is similarly caused by a remote device rather than the streamer.
It might help to know what Naim box each of you are using, Core, new or old streamer?

My Uniti Star is showing “bad gateway error 502”.

According to Google search results it appears likely that fault lies with the target server (I.e. Rovi, or whatever it’s called) rather than the Naim users’ equipment or system.

I was thinking it might be something along those lines. Either whatever server Naim use for updates on the new streamers, Rovi, or even Wikipedia or Amazon (via Rovi) but it’s just a guess. My understanding is that it’s remote servers it applies to, so I’m not sure if a local UPnP server could do this. If we could see that everyone was using the same streamer or server, that might give us some pointers.

I’m also getting this error using the iOS app.

From the rovi site the explanation given for this error code is:-

“A gateway processing the request received an invalid response from the API server or another server.”

so it does look like it’s a problem with rovi’s server(s)

Same problem for me, using Unitiserve.

1 Like

I’m using a Core.
Also excuse my ignorance. I spoke to my trusty Naim dealer who also had an inkling that it might be an issue with the metadata providers. I then checked a couple of different albums where the data was provided by different sources (Megabrainz & Rovi) both had the same issue.


1 Like

I’m 99.99% sure this is a Rovi issue. I rarely use Rovi anyway, ashtray on a motorbike etc., but its always worked or at least shown up something even if it’s wrong.
Now tonight with my NDX feed from Synology, no roon or other fancy stuff, I get the 502 warning.

Same problem in Norway too.
Uniti Serve

So if you disconnect your internet connection presumably this error message doesn’t appear? I’d try it myself, but I’m not at home at the moment.