Roon 1.7 build 571

As fellow Roonites (or should that be Roonies?) will be aware, a recent build of the software has arrived. I welcome upgrades as a general point, but where has my waveform gone?
Posts on the Roon community suggest it is still there for local music, but for me it has disappeared on my iPad and iPhone, although it is there on my MacMini. But, then again the app has not been updated yet.
It’s not a deal breaker but just disconcerting … I don’t know why I like it but I do. What do others think about the waveform: is it indicative of the flow of music, modulations in the music, or just a gauge of variations inthe volume of the music?

Interesting - I hadn’t noticed until you mentioned it. Perhaps there’s an option to turn it back on in preferences?

Apparently the waveform will reappear when both your server and control point are on the same version. There were some behind the scene changes in how this is rendered.

There’s a lag when a version appearing to when Apple and Google authorise it to be deployed. Once you have the client then it should start working again.


Ah - that makes sense. I only applied the update to my Nucleus.


The updated iPad/iPhone version hasn’t been released yet (In the States )

I suppose that means it’s a few days off here then …

My Android phone has it now

The IOS app updated this morning in the UK.

Yep I now have the latest 1.7.00571

1 Like

Yes it updated my iPhone v6; but, still no waveform. I suppose I need to upgrade my phone …

I’m getting it on my ripped albums on my iPad Pro and iMac but not on my iPhone 11 Pro. Can’t say I have ever noticed if it ever worked on the iPhone but never had a problem on the iPad Pro and iMac. It has never been present on streaming services.

Only stored downloads showing it for me. Nothing from Qobuz streaming.

Correct… it can only be displayed from local media… kind of stands to reason if one thinks about it.


My recently added music all disappeared and also lost the waveform despite all being on the new version. Eventually sorted through rebooting iPad and NUC a couple of times.

1 Like

Had a few issues with this update. Lost all my Roon bridge devices on Pi’s had to re add them like they where new devices, also having intermittent discovery with my ChromeCast devices. All where rock solid before this update.

Very strange how we are affected so differently by Roon updates. This particular update has been very beneficial to me as it appears to have resolved a couple of long term issues that were introduced by a previous upgrade (can’t remember which) last year.

I used to get an “error loading - please reload” message when opening up "What’s new"lists of albums on the Tidal tab. This has not happened since I implemented the latest Roon update.

My biggest issue also appears to have been resolved. When in ‘Roon Radio’ mode, every 2nd or 3rd track played by Roon was missing album/artist details or album artwork or background photo or any combination of these. This was particularly annoying when I heard something that I would like to add to add library. What should have been a one click process involved manually searching for the album to add.
I haven’t encountered the issue since I applied the latest update.

I have also (not yet) encountered any discovery problems with my one Chromecast device.

The one issue outlined above that I can replicate is that the music waveform (with locally stored music) no longer appears on my iPad. However, It does still appear on my Windows 10 control points.

Make sure the remote app has been updated to the latest version. They need to be on same build for the waveforms to work. Unfortunately Apple always seem to have a delay in releasing the new version of the app.


Yes - just spotted this myself on the Roon forum.

I have downloaded the latest version of the Roon remote app from the Apple store and the waveform has returned on the iPad.


Me too for my iPad but not for my iPhone. Never mind I can live with it. But I’ve just noticed a red flag … I’m up to date on both iPad and Core so assume this flag is an error?

Yes I’ve seen that metadata warning. I usually restart remote and core just to be sure to be sure.