Roon issue

Ok so I have my new NAS qnas 251+ drive running roon which is installed…
When I try and run roon on my iPad, it comes up with error loading page…please check network.
Both are on the same network, WiFi for iPad and network for NAS
Hope you can point me in the right direction for a quick fix.

Have started Roon on the QNap, using the Browser interface opened from QFinder?

I take it from the same iPad you can control your Naim equipment using the Naim App?

I would go to Roons site and read the KB as it has many useful networking tips to help you get connected if having trouble. It also list certain routers known to have issues with discovery and how to get round them.

What is your current network gear that you are using?

I will double check, when I get back home
Many thanks

Yes I can control my naim from the ipad / iphone etc
Network is on the SKY hub …unfortunately
Will have a look

Is the Naim kit wired to?

Yes, naim ND5XS2 is wired

Cool was just checking as if on wireless it could be that your wireless network is on a different subnet to the wired. But I doubt that’s the case.

There is a known issue with roon on ipads. Roon know about it but there is no definitive fix yet. I can often connect and start playing music, but when I go back later to change the music the connection is lost. Sometimes I cant connect at all. The solution is to reboot the ipad. To confirm you gave the ‘ipad’ issue and not some other network problem, try using roon on your iphone, if it works there and just not on your ipad, give it a reboot.

I try roon for a week with the Nova. I also have an unitiserve. No problem with the Nova to play on unitiserve. With roon, the uinitiserve do not show. I try to add it , but it never work.
With the ipad, it lost the connection very often.
And with my computer running win 10, i have to resart my computer after leaving roon. A blank page appears and nothing happens.
So I cancel after the free try, to much bug. To complex to work with. I am not a tech ,I just to listen music.

Roon works fine with my Unitiserve. I run it on a MacBook at the moment, and it has performed flawlessly. Initial setup can always involve a bit of head scratching, but worth persisting with, I think.

What is this so called ‘known’ iPad issue. iPads work fine with Roon… never ever had one issue…
Most likely the OPs switchport on his Sky router are interfering with layer 2 discovery mechanism used… and causing issues.
BTW you might find letting your broadband router operate at ipv6 helps… Roon will use that if available and by its very nature ipv6 is far better at discovery.
Most of my home network runs at ipv6 link layer addresses or IPv4 embedded ipv6 addresses, apart from when talking to Naim which stubbornly sticks at IPv4 only.

Ipv6 is often faster when on the web and internet as often less address processing/translation is performed… and the ipv6 routes be less busy… very loosely like comparing 2.4GHz Wifi with 5GHz Wifi.

My iPad showing my Roon Core address using an IPv4 embedded ipv6 address.

I also don’t have any iPad with Roon problems. I suspect it’s some small oversight in this setup. Over here Roon worked just fine with multiple iPads on the default settings.

1 Like

Yes @Simon-in-Suffolk no doubt there is more at play here (no pun intended). The symptom though is that the ipad (and only the ipad) loses connectivity to the core. Which is odd when an iphone has no issues. If you google ‘roon ipad not connecting to core’ there’s more discussion to be found. Your comment about ipv6 is interesting, and something I had not considered. I’ll make that change and see if there are any differences.

1 Like

Thanks for the help. Could it be the routeur. I use the routeur from my internet provider. I have many apparels connect via wire and wi-fi. (More than 10).

My Roon on iPad and iPhone is working now, advice from Roon was to just restart my NAS drive…
Will test more

Update. Set router to use IPv6 havent had my iPad disconnect from roon core since…Thanks @Simon-in-Suffolk

Glad to be of service :grinning:

Yes those who have issue with discovery when using IPv4 may find IPv6 more reliable to use with non Naim devices. I wish Naim would use Ipv6 as well on their streamers… it does certain things so much better.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.