Roon, LMS-to-UPnP failure

Ive just updated the LMS-to-UPnP software from Sourceforge. However, now neither my NDS nor my 'Qutes respond. I can play music using Roon on my laptop, iPad and iPhone but not through my Naim gear.
I have stopped and rebooted by Naim streamers but to no avail. Roon shows the music playing but nothing comes out …
My NDS uses an Audiostore Prestige with a built in Sonicorbiter, whilst my 'Qutes rely on the LMS-to-UPnP software, which runs on a MacMini and a MacbookPro. Ill try to get everything working on a couple of RPis in the morning. But in the meantime does anyone have any ideas what is wrong?
I’ve been looking for older versions of the LMS-to-UPnP software, and have tried a version from January but to no avail.

I’ve had trouble with version 1.4.x running within Logitech Media Server on my QNAP and also on a Pi.

It worked but I experienced hissing like an out of tune FM tuner on high res material.

I have reverted to an older version.

On the Pi I did

sudo wget

I have been using version 1.31.0 without issues.

If you can’t wget you should be able to get directly from the URL above.

1 Like

Had not moved off 1.27.0

1 Like

Thanks for the advice gentlemen (@trickydickie and @simon.pepper). I had reinstalled an older version last night, all the units showed up under the zones but no sound emanated. Now this morning the only zones showing are the iPad and Apple TV.
Once breakfast has settled I’ll tackle the thing again.
It’s strange that the Audiostore Prestige does not show up - I will need to check the setup in Roon and the SonoreBridge.
Ah the SonoreBridge needed restarting … and it works.


I’ve found restarting the NDS can sometime help.

When I switched over from the QNAP to a clean Pi installation the static noise re-appeared. A restart of the NDS stopped this and all has been well since.

1 Like

I installed an older version of the Lms2upnp software, but the problem persists. As the screensho shows the track indicator is active, but there is no progress on the lower bar.
I did not get the RPi setup today, job for tomorrow.

Have you checked your config file hasn’t reverted and has the wrong setting for Roon=?

Ah good point.
Seems that the config file is missing …
Tried setting it up with -i config.xml but the file was not created. Will try again. Thanks for the tip.

Success - looking at the terminal screen when I tried to run the latest update I noticed a connection error. Sure enough one of my patch cables had popped out of the switch. I noticed that it had not been inserted in sequence so was probably under extra tension. So powered down and corrected the order of leads from the patch panel.

Basic school boy error - not checking connections. Smiles all round and I can go back into the garden with “sketches of Spain” on in the background coming out of the study / garden doors. At least the dog will be happy that I’m outside with him.
Thanks again for all your support.

1 Like

If this is the hiss I’ve just experienced on a couple of albums, it was with hi-res music. How frustrating, I’ll have to go back a few versions. I had hoped 1.4.2 had solved it.

Yes, sounds like an un-muted FM tuner between stations. Not good if your pre-amp is at 9 o’clock or above!

I’m not really sure what causes it. I believe bandwidth is a factor as a while ago our high speed Virgin (200mbps) connection went down for a couple of days and we failed over to our backup 5mbps ADSL connection. Over this time 24/192 music would do this hissing consistently, everything else was OK.

Whilst mucking about with a Raspberry Pi I’ve had this on and off but with 1.4 it seemed to do it all the time with hi-res whereas 1.3.x seems OK apart from the odd moment, normally when I have stopped play using the NDS front panel control and later un-paused within Roon. I can kind of forgive this as Roon won’t know I’ve stopped playback and the 2 can get out of step.

1 Like

It’s interesting that it’s an LMS thing, it does not appear to happen via the sonicorbiter.

The latest version is no better (1.40.4), and now 1.31.0 is playing up with Hi-Res, so back a step to 1.30.0. And try again …

Try rebooting your streamer first, it solved my issue when rolling back.

1 Like

Thanks again for reminding me that it’s only a computer. Back with 1.30.0 …
All this computer stuff is not getting the ice cream made …

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.