Roon + QNAP + AAC

I have started a Roon trial and managed to get things working.

There is one issue that has cropped up, it’s well known on the Roon Forum, but to resolve it requires more computer knowledge than I am capable/comfortable with.

The issue is AAC files cannot be played from a QNAP NAS through Roon, works OK with Asset/Naim app. It is a known issue and something to do with QNAP.

Has any member here come across this issue and found an easy fix? The Roon forum talks about getting into the code of the NAS!!!

The only option I can see, is to convert all the AAC files to some other format.

I have 14K plus tracks and can’t see an easy way to identify the AAC ones, but it could be a project to find them all and convert.

I don’t wish to buy a new NAS.

You need to update the version of ffmpeg installed on the nas, instructions are here. Relatively straightforward to do.

Thanks Robert

I have seen that and it means nothing to me with no idea where to start. Where is ffmpeg situated?



The instructions here tell you how to update the version by renaming the old one and replacing with the newer one installed via app centre. If you can browse the qnap folders you should be able to do this.

Got the new ffmpeg on my NAS. Have used Terminal on my MAC to get into the NAS, but all that code confuses me.

I’ve also gone another route and installed the Cayin option, but that doesn’t seem to help.

Will now put a record on:)

  1. Find where the current version of ffmpeg lives, mine (v3.3.6) was installed here…

cd /usr/local/medialibrary/bin

Above means change directory to that folder

  1. Rename it to ffmpeg_OLD

mv ffmpeg ffmpeg_OLD

mv means move. This renames the existing file

  1. Go to the location of the new version

cd /opt/ffmpeg

Change directory again

  1. copy it into /usr/local/medialibrary/bin (or wherever your original ffmpeg was located)

cp ffmpeg /usr/local/medialibrary/bin/

This is a copy command
You can either issue these dos or bash type commands into a terminal
Or if you have drag and drop view of the folders and files you can do it that way

Well, after about 6 hours, yesterday and today I have managed to do it.

AAC works.

I used a thing called WinSCP on a windows machine (I use MAC). Couldn’t get that Putty thing to work. It was a bit of a leap, as I copied and pasted what I hoped was the right bit of the folder that the new ffmpeg came in.

Anyway it works, thanks for your patience.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.