Safari flunky on iPadOS 16.1

I’m having a horrid time with Safari on my iPad since upgrading to 16.1, very slow to load pages, the search bar freezes when typing text etc. I’ve tried deleting the Safari history, resets etc to no avail. When trying Chrome, I have no issues.

Any suggestions, or anyone else having issues?

I’ve a had a few minor issues with the page jamming etc. There was an upgrade yesterday to 16.1.1 that’s seemed to fix the problem.

The issue I’m struggling with on my iPhone is getting the cursor to go where I point it too. I’ve find the touch idea so damn annoying and inaccurate.

1 Like

Yes, I’m on 16.1.1, which seemed better for a while, but it’s still really poor. It’s weird that Chrome work fine but Apples own browser is almost unusable. Very odd. I’ll try another hard reset.

On my iPad Air 4, everything is ok with iPadOS 16.1.1

EDIT : I add, that I love my iPad Air 4 and iPadOS, rather than my MacBook Pro and macOS Ventura.
I use my iPad every days. My MBP only once a month maybe.

next buy, an iPad Pro 12.9", buth only when they put the front cam on the landscape side as the new iPad 10th

1 Like

Not sure if you’ve tried it already, but I find the technique of moving the cursor around by pressing and holding the space bar is way more effective than flailing and stabbing with clumsy fingers!

(No Safari issues on my iPad Pro 12.9 to share)

2 Likes

Cheers I’ll give that a go, anything has got to be better than just poking around hoping it’ll land in the right place.

1 Like

Gosh, I never knew you could do that, it works a treat too. Cheers!

1 Like

Alan you’re a wiz I’ve been struggling with the cursor on my stupid iPhones for years. Just tried it and can’t believe how easier it is.

I owe you a beer.

1 Like

Make that 2 beers :grinning:
Great tip

2 Likes

@Mike_S

This might related to an experimental feature in Safari, which has been giving problems with MoOde Audio on iPads (pages take up to 50 seconds to load!).

Try this:

open Settings & scroll down the left panel to find Safari

open Safari & scroll down the right panel to find Advanced

open Advanced , then in the right panel, open Experimental Features .

Scroll down the right panel to find Lazy iframe loading & Lazy image loading

uncheck both

God that a long list of things I have no idea of what they do or don’t do. One of those items was already unchecked however I’ve unchecked the other now as well.

Thanks for that, but it doesn’t seemed to have fixed it. Pages that are already open reload okay, but when I open a new tab, entering text doesn’t show until about 60 seconds after entering it.

I don’t know why basic stuff like this should become broken after a software update. I think I might need to resort to a full reset.

Mike do you turn your phone off much, I find that actually shutting the thing down does clean a few things. We turns out off at least once a week and find the phone works much better.

I try to remember and often forget. This issue is only with the iPad though and I’ve forced restarted it about a dozen times now.

Should be the same with the iPad. Worth a try.

Cursor? What cursor? How did I miss that? :roll_eyes:

I find that iOS and iPad OS are increasingly unintuitive and ‘actions’ happen that I don’t expect or want due to inadvertent actions on my part.

I’m really starting to think I’m getting old.

Almost every day I rant at the AppleTV interface when streaming services do things I simply don’t want, then the kids say ‘dad, pass the remote’ and they sort it out.

If anyone has a clue how to stop BritBox automatically playing the next episode seconds too early after minimising what is currently playing I’d love to know.

Watching the recently added Not The Nine O’clock News episodes has had me in fits of laughter with a few sketches I’ve not seen in years, but when the credits roll the playback gets minimised and next episode starts prematurely cutting off the end-credit sketch punchline.

1 Like

I don’t use the space bar but just press down somewhere near until the finger in question moves the cursor. Maybe the new version has other options, but I haven’t upgraded yet.

Phil