Server not showing on my Atom

Anyone had this experience? My innuos server is not showing on my Atom app on iPad. Both are innuos and Atom are showing as present on my network but in the Naim app the innuos is not present.

1 Like

Normally restarting the app will bring the server back. If not then restart the Atom and the server too. If none of that works, then restart the router as well.


Are both devices in the same IP range? Is your server one with a dedicated streamer port and are you using it?

Experienced something like that recently. Tried killing the app and restarting NAS and Atom. But it didn’t help. What apparently solved it, was rebooting my iPhone.

When you say “killing the app”, you do mean stopping it completely and restarting and not just putting it into the background?

Putting it into the background and bringing it out to the foreground again achieves nothing, To kill it you have to get into app switcher mode and then swipe the app upwards and away. You probably know all this, but I am very surprised that you needed to restart your iPhone to fix it.



Hi David. Yes, I do indeed understand the difference between putting the app in the background on killing/stopping it using the app switcher :wink:

It would be fair to mention, that this was at the end of a long journey of updating the firmware on the QNAP NAS, and bewilderment of not being able to see the server in the Naim app, but seeing the NAS on the rest of network, also on non-Naim network players.

So after booting the NAS (several times), killing the server, and restarting it, booting my Atom as well as my QB, restarting the router and killing the app, all of which had no effect (aside from a fair amount of frustration…) I ended up performing a hard reset of my iPhone, and that (apparently) did the trick… If any of the previous steps contributed to the rediscovery, I honestly don’t know. I did however try one thing at a time, testing if the different steps had an effect.

I was just as surprised as you, when the restart actually worked, but I gave up on understanding network issues a long time ago, and were just happy to finally being able to see/access the server again through the Naim app.

As such, I thought it only fair to contribute with what worked for me, since it is easy to try, and it could potentially do the trick for the OP.



Very interesting and highly confusing! Anyway thanks for the reply and I certainly agree it’s always worth sharing fixes even if one doesn’t understand them.


Thanks for all the replies, the only one I haven’t tried is re booting my ipad, so I’ll give that a go. I have rebooted the hub, the Atom, the server , the app, so only the ipad left to try.

If you’re doing these restarts one device at a time, the final last ditch attempt you might try is a full network reboot. Turn off everything, then fully start up the router. Then each client device, one at a time. If it works, you still won’t have diagnosed the issue, but it might just help.

Yes I would like to know what causes this, very annoying and one reason I’ll never let my LP12 go, at least I can still play a record, old school.

Re setting the iPad has done the trick, the only thing I didn’t do. Still rather annoying as to why it does this.

It’s threads like this that suppress any ideas I might have about trading my CDP for a streamer…

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.